On 8/1/2011 3:56 AM, Corinna Vinschen wrote: > Looks good to me. As you probably noticed, I didn't manage to move > the db functions into rebase-dump.c so far, though. Otherwise there > wouldn't be a need to have your own load_image_info function. > > Do you want me to do that before or after you applied your patch?
(a) I figured it should come after, and (b) at first, rebase-dump probably just needs to rename its version of load_image_info to avoid conflicts, since the two versions are (slightly) different. I agree that rebase-dump.exe SHOULD use the same load_image_info() that the "real" rebase.exe does, but that ought to be a third patch IMO. Because rebase-dump's version needs a SMALL rewrite to use the dump_* functions -- and dump_*_entry needs a tiny tweak to make that work right -- but most importantly, the new combined load_image_info needs to have the 'verbose' option passed down. So, in your patch, I think just ignoring rebase-dump entirely -- /except/ for changing the name of its load_image_info -- is the way to go. Then I'll post a third patch, discussed separately, that tries to merge the two versions. -- Chuck
