Thanks for replying, René. My responses are embedded inline.

René Berber wrote:
When I tried running the C:\cygwin\lib\Singular\startxserver.bat
-----------------------------------------^^^^^^^^^^^^^^^^^^^^^^^^^ That is not from the Cygwin distribution.

Dunno. I ran the latest official Cygwin setup.exe, and chose to
install *all* the packages at one of the mirrors listed in the
install window:

ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/sources.redhat.com/cygwin

The Singular stuff came with that.

You seem to have installed something else on top of Cygwin.

Nope. Just the stuff that came through the Cygwin install.

----------------------------- Snip ----------------------------- 'C:\cygwin\lib\lapack' is not recognized as an internal or external command, operable program or batch file. ----------------------------- Snip -----------------------------

So?  That means the above .bat file is trying to execute something
else that also doesn't come with Cygwin... and is not even an
executable.

Again. Dunno. It's what came with the distro.

I then tried the /usr/X11R6/bin/startxwin.bat script and got the same error.

If you received the same error message then something, not Cygwin,
messed up your installation.  Same error probably means you executed
the same file, are they really named startxserver.bat and
startxwin.bat, or is just a typo?

Nope. Two different files. startxserver.bat came with the
Singular stuff. startxwin.bat is the standard batch file
included with Cygwin in /usr/X11R6/bin.

Again, the two things to remember here are that startxwin.sh
works just fine, and this exact same distro -- Singular stuff
included -- works just fine on my XP machine. Moreover, before
I rebuilt this Win2K box, this distribution worked just fine
as well.

I've tried totally removing and reinstalling Cygwin a couple of times already.

Did you check what was left on the above directory?  If Cygwin did
not install whatever is there it will not delete it.

I completely deleted the Cygwin directories, which included
the Singular stuff.

Thanks again,

Scott


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply via email to