Scott Fordin wrote:

> Thanks for replying, René. My responses are embedded inline.
> 
> René Berber wrote:
>>> When I tried running the C:\cygwin\lib\Singular\startxserver.bat
>> -----------------------------------------^^^^^^^^^^^^^^^^^^^^^^^^^
>> That is not from the Cygwin distribution.
> 
> Dunno. I ran the latest official Cygwin setup.exe, and chose to
> install *all* the packages at one of the mirrors listed in the
> install window:
> 
> ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/sources.redhat.com/cygwin
> 
> The Singular stuff came with that.

You are right.

I just checked http://cygwin.com/packages and the startxserver.bat comes with 
singular-icons (strange, but then I don't use Singular).

[snip]
>> So?  That means the above .bat file is trying to execute something
>> else that also doesn't come with Cygwin... and is not even an
>> executable.
> 
> Again. Dunno. It's what came with the distro.

OK, it seems that the startxserver is not even a valid script (I haven't 
tested, I don't have Singular, I'm saying that from the result you had).

Question: Why were you trying to start XWin with that bat file?  I don't know 
what it is for, but seems redundant.

>>> I then tried the /usr/X11R6/bin/startxwin.bat script and got the same
>>> error.
[snip]

Now to the real problem: are the files different?

They should be.  There is no reference to the Singular directory in the normal 
startxwin.bat file... check for symbolic or hard links, perhaps Singular's 
(post)installation is doing something wrong.

I see no other explanation for getting the same error message.
-- 
René Berber


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply via email to