René Berber wrote:
Scott Fordin wrote:

Thanks again for replying, René. Sorry it took me a couple of
days to get back to you. My responses are embedded below.

OK, it seems that the startxserver is not even a valid script (I
haven't tested, I don't have Singular, I'm saying that from the
result you had).

Strange thing though is that it does work on another machine.

Question: Why were you trying to start XWin with that bat file?  I
don't know what it is for, but seems redundant.

Well, the way things install, a "Start X Server" shortcut is
installed on the desktop. It's more handy than opening a bash
shell and then running startx from there. I've tried configuring
a similar shortcut for startx, but I can't get it to work. Since
startxwin.bat fails with the same error as startxserver.bat, I
can't just use that on the desktop instead. I don't have a
standalone version of Perl installed, so I can't run the .sh
version of the script. I don't know how else to do it. I looked,
but I didn't find an answer, but do you know of a way I can pass
a shell command to bash.exe from the Windows command prompt?

I then tried the /usr/X11R6/bin/startxwin.bat script and got
the same error.
[snip]

Now to the real problem: are the files different?

There are differences, but none seems significant vis a vis
this particular problem. I've attached the diff output. I
can't even figure out where the lapack libraries are being
called...

They should be.  There is no reference to the Singular directory in
the normal startxwin.bat file... check for symbolic or hard links,
perhaps Singular's (post)installation is doing something wrong.

I see no other explanation for getting the same error message.

Thanks again,

Scott
5c5
< REM
---
> REM 
10c10
< REM example, if you installed Cygwin in \foo\bar\baz\cygwin, you will need
---
> REM example, if you installed Cygwin in \foo\bar\baz\cygwin, you will need 
20a21
> SET RUN=%CYGWIN_ROOT%\bin\run -p /usr/X11R6/bin
145c146,166
< run XWin -multiwindow -clipboard -silent-dup-error
\ No newline at end of file
---
> %RUN% XWin -multiwindow -clipboard -silent-dup-error
> 
> 
> REM Startup an xterm, using bash as the shell.
> 
> %RUN% xterm -e /usr/bin/bash -l
> 
> 
> REM
> REM Startup the twm window manager.
> REM WARNING: Do not use an external window manager in conjunction with
> REM the ``-multiwindow'' command-line parameter for XWin.  Doing so
> REM would start two window managers, which is never supposed to happen.
> REM
> 
> REM %RUN% twm
> 
> 
> REM Set a background color.  Only needed when not using -multwindow for XWin.
> 
> REM %RUN% xsetroot -solid aquamarine4

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply via email to