Scott Fordin wrote:
[snip]
> Strange thing though is that it does work on another machine.

Very strange, the differences you sent don't show an invalid script at all.  
One of the 2 files has \r\n endings (that's the reason for the first 2 
differences) but as long as they are being executed by command.com it doesn't 
matter.

[snip]
> Well, the way things install, a "Start X Server" shortcut is
> installed on the desktop. It's more handy than opening a bash
> shell and then running startx from there. I've tried configuring
> a similar shortcut for startx, but I can't get it to work.

You can create a shortcut to startx.sh and then edit its "Properties" so the 
target ends up like: C:\cygwin\bin\run.exe -p /usr/X11R6/bin/ bash --login -c 
startx 
[Ref:http://permalink.gmane.org/gmane.os.cygwin.xfree/16545]

I use a shortcut to start X Windows only (no xterm):

C:\cygwin\bin\run.exe -p /usr/X11R6/bin XWin -multiwindow -clipboard 
-silent-dup-error -dpi 100

> Since
> startxwin.bat fails with the same error as startxserver.bat, I
> can't just use that on the desktop instead. I don't have a
> standalone version of Perl installed, so I can't run the .sh
> version of the script. I don't know how else to do it. I looked,
> but I didn't find an answer, but do you know of a way I can pass
> a shell command to bash.exe from the Windows command prompt?

If your path includes the location of Cygwin's binaries you can use run as 
above.

[snip]
> There are differences, but none seems significant vis a vis
> this particular problem. I've attached the diff output. I
> can't even figure out where the lapack libraries are being
> called...

Nowhere... so what is being run?
-- 
René Berber


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply via email to