I am not sure if this is the appropriate group. In addition, searching through
these gmane newsgroups is not straightforward since Google groups does not 
return them.

Startx fails to initialize when it worked yesterday. I ran setup and the 
process may have not
completed (it was late and I needed to sleep). After running setup.exe again, I 
navigated to the
System category and reinstalled rebase. Then I reviewed the README file; kill 
all processes
associated with cygwin; ran ash; and typed /bin/rebaseall -v; the utility 
performed some actions and
returned without errors.

I fired up a cygwin window and startx would still not initialize. The console 
gave me the following
font error.

sageQueue trapped WM_QUIT message, exiting main loop.
winClipboardProc - XDestroyWindow succeeded.
FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount is 2, should be 1; 
fixing.

The cygwin console appears fully functional. The console has returned some 
errors when running make,
but these issues may be completely separate. Please give me whatever insight 
you may have on these
scenarios. I have already spent considerable time troubleshooting these issues 
and need better
guidance.

After rebooting the computer and typing startx, cygwin gave me the following 
error message. 

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 6.8.99.901-4

Contact: cygwin-xfree@cygwin.com

XWin was started with the following command line:

X :0 -multiwindow -clipboard

_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
winValidateArgs - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
(II) XF86Config is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
winDetectSupportedEngines - Windows NT/2000/XP
winDetectSupportedEngines - DirectDraw installed
winDetectSupportedEngines - DirectDraw4 installed
winDetectSupportedEngines - Returning, supported engines 00000007
winSetEngine - Multi Window or Rootless => ShadowGDI
winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 2048 height: 768 depth: 32
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
winInitMultiWindowWM - Hello
winMultiWindowXMsgProc - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of shar
ed memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409)
(--) Using preset keyboard for "English (USA)" (409), type "4"
Rules = "xorg" Model = "pc105" Layout = "us" Variant = "(null)" Options = "(null
)"
(--) 5 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from li
st!
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from
list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from li
st!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from
 list!
winPointerWarpCursor - Discarding first warp: 1024 384
winInitMultiWindowWM - pthread_mutex_lock () returned.
winProcEstablishConnection - Hello
winInitMultiWindowWM - pthread_mutex_unlock () returned.
cat: winMultiWindowXMsgProc - pthread_mutex_lock () returned.
/home/Ferdie/.Xauthority: No such file or directorywinInitMultiWindowWM - DISPLA
Y=127.0.0.1:0.0

winMultiWindowXMsgProc - pthread_mutex_unlock () returned.
winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0
winInitClipboard ()
winProcEstablishConnection - winInitClipboard returned.
winClipboardProc - Hello
winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the di
splay.
winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the disp
lay.
DetectUnicodeSupport - Windows NT/2000/XP
winClipboardProc - DISPLAY=127.0.0.1:0.0
winClipboardProc - XOpenDisplay () returned and successfully opened the display.

winProcSetSelectionOwner - Clipboard not yet started, aborting.
winProcSetSelectionOwner - Clipboard not yet started, aborting.

waiting for X server to shut down winClipboardProc - winClipboardFlushWindowsMes
sageQueue trapped WM_QUIT message, exiting main loop.
winClipboardProc - XDestroyWindow succeeded.

winClipboardIOErrorHandler!


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply via email to