I am reposting my problem since it has not been resolved after forty hours of 
troubleshooting the
situation.   Even though this mail list gave me some insight, I still need 
better guidance. General
comments will not help this newcomer decipher the error log and deduct the 
course of action. This
post is my last effort to avoid installing and reinstalling cygwin, which will 
provide a challenge
after setting up ssh and all the paths. 

Startx failed to initialize when it had been working in the past. I ran setup 
and the process may
have not completed (it was late). After running setup.exe again, I navigated to 
the System category
and reinstalled rebase. Then I reviewed the README file; kill all processes 
associated with cygwin;
ran ash; and typed /bin/rebaseall -v; the utility performed some actions and 
returned without
errors.

I fired up a cygwin console and startx would still not initialize. The console 
gave me the following
font error.

sageQueue trapped WM_QUIT message, exiting main loop.
winClipboardProc - XDestroyWindow succeeded.
FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount is 2, should be 1; 
fixing.


I have also removed the clipboard and multiplewindows arguments from the startx 
script; it did not
help. The clipboard module is the main advantage of running X for me.  
Startxwin.bat and starxwin.sh
do not launch Xwin either. Xwin should not be conflicting with a firewall; 
since this system does
not have software firewall.

After reinstalling X and all fonts, I mounted the font path and still receive 
this error.

Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from li
st!

The cygwin console appears fully functional. Please give me whatever insight 
you may have on these
scenarios. I can read the logs, but I can not decipher them am not familiar 
with the action
necessary.  I found this interesting commentary as well (it didn't work 
either). 

http://quantumg.blogspot.com/2006/11/god-damn-i-hate-cygwin.html


#--------------------------------------------------------------------------------------#
$ startx

_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
(II) XF86Config is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 2048 height: 768 depth: 32
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
winInitMultiWindowWM - Hello
winMultiWindowXMsgProc - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of 
shared memory support in
the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409) 
(--) Using preset keyboard for "English (USA)" (409), type "4"
(--) 5 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from 
list!
winInitMultiWindowWM - pthread_mutex_lock () returned.
winProcEstablishConnection - Hello
winInitMultiWindowWM - pthread_mutex_unlock () returned.
winMultiWindowXMsgProc - pthread_mutex_lock () returned.
winInitMultiWindowWM - DISPLAY=127.0.0.1:0.0
winMultiWindowXMsgProc - pthread_mutex_unlock () returned.
winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0
winInitClipboard ()
winProcEstablishConnection - winInitClipboard returned.
winClipboardProc - Hello
DetectUnicodeSupport - Windows NT/2000/XP
winClipboardProc - DISPLAY=127.0.0.1:0.0
winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the 
display.
winClipboardProc - XOpenDisplay () returned and successfully opened the display.
winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the 
display.
winProcSetSelectionOwner - Clipboard not yet started, aborting.
winProcSetSelectionOwner - Clipboard not yet started, aborting.
winClipboardProc - winClipboardFlushWindowsMessageQueue trapped WM_QUIT 
message, exiting main loop.
winClipboardProc - XDestroyWindow succeeded.

winClipboardIOErrorHandler!

#----------------------------------------------------------------------------------#
$ startxwin.bat
startxwin.bat - Starting on Windows NT/2000/XP/2003
      3 [main] run 728 tty_list::allocate: No tty allocated
      3 [main] run 4424 tty_list::allocate: No tty allocated

#----------------------------------------------------------------------------------#
[EMAIL PROTECTED] /usr/X11R6/bin
$ startxwin.sh

_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
(II) XF86Config is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 2048 height: 768 depth: 32
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
winInitMultiWindowWM - Hello
winMultiWindowXMsgProc - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of 
shared memory support in
the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409) 
(--) Using preset keyboard for "English (USA)" (409), type "4"
(--) 5 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from 
list!
winInitMultiWindowWM - pthread_mutex_lock () returned.
winInitMultiWindowWM - pthread_mutex_unlock () returned.
winMultiWindowXMsgProc - pthread_mutex_lock () returned.
winInitMultiWindowWM - DISPLAY=127.0.0.1:0.0
winMultiWindowXMsgProc - pthread_mutex_unlock () returned.
winProcEstablishConnection - Hello
winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0
winInitClipboard ()
winProcEstablishConnection - winInitClipboard returned.
winClipboardProc - Hello
winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the 
display.
winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the 
display.
DetectUnicodeSupport - Windows NT/2000/XP
winClipboardProc - DISPLAY=127.0.0.1:0.0
winClipboardProc - XOpenDisplay () returned and successfully opened the display.
winProcSetSelectionOwner - Clipboard not yet started, aborting.
winProcSetSelectionOwner - Clipboard not yet started, aborting.

#----------------------------------------------------------------------------------#
[EMAIL PROTECTED] /usr/X11R6/bin
$ mount
c:\cygwin\usr\X11R6\lib\X11\fonts on /usr/X11R6/lib/X11/fonts type system (binmo
de)
C:\cygwin\bin on /usr/bin type system (binmode)
C:\cygwin\lib on /usr/lib type system (binmode)
C:\cygwin on / type system (binmode)
c: on /cygdrive/c type system (binmode,noumount)
d: on /cygdrive/d type system (binmode,noumount)
e: on /cygdrive/e type system (binmode,noumount)
f: on /cygdrive/f type system (binmode,noumount)
g: on /cygdrive/g type system (binmode,noumount)
h: on /cygdrive/h type system (binmode,noumount)
i: on /cygdrive/i type system (binmode,noumount)
z: on /cygdrive/z type system (binmode,noumount)



--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply via email to