On 15/09/16 22:18, Marco Atzeri wrote:
On 14/09/2016 18:04, Cesar wrote:
Marco, thanks for your response, mosml is a lightweight implemetation
of SML -standard ML, a functional programming language similar to
Haskell-, i tried running "--trace" and it does the same thing. I've
just confirmed that is not an issue with the make command since it
worked for the M4 macro processor. i've done the same thing in ubuntu,
it worked there but not here.

assuming that is https://github.com/kfl/mosml

The build system is missing a configuration system
(like cmake or autoconf ). The Makefile are hardcoded
and of course the build system does not know cygwin
and the outcome is bad.

You need to manually modify the Makefiles, but usually
this thing are complicated if possible at all.

There are some instructions for building under Cygwin in comments in one of the makefiles [1]. However, that may not help - there is an open ticket that mosml doesn't build on Cygwin [2].


[1] - https://github.com/kfl/mosml/blob/master/src/Makefile.inc#L111
[2] - https://github.com/kfl/mosml/issues/37

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply via email to