I've been running 2.9.x under windows 7 on my 16GB laptop for a long time 
(probably the 
last year), when late last week my ssh outbound quit working.  The failure is 
indicated with 
this error message:

ssh: Could not resolve hostname csu6220509.vzbi.com: Non-recoverable failure in 
name resolution

I checked the forums, and what I saw seemed to relate to connecting to VM boxes.
In my case, this is not the cause of the failure.
This machine is my company provided (and software managed) laptop, so I don't 
have a 
lot of control over (in fact, I don't have hardly any control) what gets 
"pushed" to it.
However, the one thing that I noticed that seemed to coincide with the failure 
is that
the company pushed an "Elastica Reach Agent 1.0.20930.0" to my machine.

I thought the issue might have been a version problem, so I updated to the 
Cygwin version
$ uname -a
CYGWIN_NT-6.1 TCO10106LKVTAHB 2.10.0(0.325/5/3) 2018-02-02 15:16 x86_64 Cygwin

That didn't fix the problem.  I've also tried some other utilities,  which are 
such as mobaxterm(Cygwin based), babun(Cygwin based)  and putty.  All those 
seem to work

Once I determined that it wasn't my actual network stack, I then tried running 
ssh under
strace, and now it works.  So, I can use ssh if I use it with strace, but 
natively by itself
it continues to get the failure in name resolution.

Any clues, hints or pointers on how to go about either determining what the 
problem is, or 
how to clean it up?

(I am also seeing the same issue with wget, and strace clears that up also
$ wget http://linux1.vzbi.com
--2018-02-22 09:55:38--  http://linux1.vzbi.com/
Resolving linux1.vzbi.com (linux1.vzbi.com)... failed: Non-recoverable failure 
in name resolution.
wget: unable to resolve host address 'linux1.vzbi.com'



Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply via email to