Thanks for responding.
I have to apologize in advance. I don't know the answer to your question.

It's the lpr that executes under the bash system once CYGwin starts. I did a
search for lpr.exe under windows and found one under an obscure windows
directory. When I tried to execute it said it can't run on my PC? Windows
doesn't seem to have a native lpr?
I don't know how to find the Cygwin lpr that I'm using. I remind you that
print, catting to $PRINTER don't work either.
If you tell me how I'll find which lpr is running under bash in Cygwin.



-----Original Message-----
From: Andrey Repin [] 
Sent: Thursday, February 22, 2018 5:47 PM
Subject: Re: Printing (lpr, print, cat > <various names> returns printer not
valid or no longer available


> I have read the FAQs and 100's on general web page discussions re 
> printing and they all talk about \\ <file://%3cserver%3e/%3cprinter> 
> <server>\<printer> as the answer, but I only get the not valid response.
> I've tried many varients of \\, //, "", ''  and escaping 2, 4 etc 
> times  and it doesn't make any difference.

I have only one question: are you using Cygwin's or Windows `lpr' ?


> I am running Windows 10 and can print to the printers in the device 
> list in Windows without problems from Windows. The printer in question 
> is Postscript capable HP print on the local network with no particular 
> "server" that I am aware of.

> I even tried making a shorter printer name with no spaces or special 
> characters, The OS sent that name when I started Cygwin, but it again 
> didn't make any difference.

> Here is some information, any help would be greatly appreciated.


> I find it hard to believe I'm the only one having this problem.


> By the way I installed "everything" when I installed Cygwin, took 
> almost 5 hours - I'm very patient, but everything worked fine and it 
> used about 150+G of disk space, no problem.


> Here is some information, any help would be greatly appreciated.

> $ lpr -D

> Windows printer name = 'NPIFA1F16 (HP Color LaserJet CP2025n)'

> isWindows9x = 0, isWindows2K_NT4 = 1

> Printer name: 'NPIFA1F16 (HP Color LaserJet CP2025n)', Port name:
> 'WSD-4c342c10-53d8-4569-8ddf-131b36eb360b.0063'

> Printer name: 'Microsoft XPS Document Writer', Port name: 'PORTPROMPT:'

> Printer name: 'Microsoft Print to PDF', Port name: 'PORTPROMPT:'

> Printer name: 'HP ePrint + JetAdvantage', Port name: 'HP ePrint'

> Printer name: 'Fax', Port name: 'SHRFAX:'


> rodne@Rodney-HP-Envy ~

> $ lpr -d \\\$PRINTER .bashrc

> lpr: printer error: can't open '\$PRINTER' for writing: 
> The printer name is invalid.


> rodne@Rodney-HP-Envy ~

> $ lpr -d '\\\NPIFA1F16 (HP Color LaserJet CP2025n)' 
> .bashrc

> lpr: printer error: can't open '\\\NPIFA1F16 (HP Color 
> LaserJet CP2025n)' for writing: The printer name is invalid.


> Can't initialize "prn", print doesn't work either, copying directly to 
> the printer doesn't work, cating and pipling to lpr doesn't work


> Rod (2/22/18)


> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

With best regards,
Andrey Repin
Friday, February 23, 2018 01:44:54

Sorry for my terrible english...

Problem reports:
Unsubscribe info:

Reply via email to