On 06/03/2018 17:58, Steinar Bang wrote:
Here's what I do:
  - Start cygwin XLaunch for the Windows 10 desktop
    - Select "Multiple windows"
    - Launch the lxterminal locally
  - In an lxterminal tab do the command
     ssh -Y myhost.mydomain.lan
  - In the ssh session give the command

What happens is that:
  1. First the banner starts and displays normally
  2. Then a window shows up squashed to a point, there is an eclipse icon
     (possibly intended for the toolbar) near the point, but it can't be
  3. It's not possible to stretch or resize the point
  4. I tried pressing the return to select the default in the workspace
     select dialog (which is the first dialog to open when eclipse is
     started normally)

I think the problem is with cygwin X and/or the way I'm running it,
because I have tried doing "ssh -Y " from a terminal window on the
debian computer's mate desktop to a different computer, and then doing a
new "ssh -Y" from the remote computer and back to the debian and then
started eclipse on the debian computer.  And that eclipse started
normally, running through two ssh X forwards.

Does anyone know what might be causing the eclipse display problem, and
what I can do to fix it?

This seems like a problem with the integrated WM not doing what is expected, Java programs do seem to be problematic in this regard. So, you can probably work around this by running the Cygwin X server in windowed, rather than multiwindow mode.

I tried to reproduce this, but eclipse worked ok for me.

Can you tell me the versions of Xwin, debian and eclipse you are using?

Jon Turney
Volunteer Cygwin/X X Server maintainer

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply via email to