I logged into my Win7 laptop and I saw it was having some connection
problems, so I decided to reboot.

After the reboot I found that Cygwin had some basic problems.  I brought up
a mintty window (C:\cygwin64\bin\mintty.exe -e /bin/bash --login) and the
prompt looked odd.  It wasn't the PS1 value that I set in my .bashrc. It
also seemed to be saying that my current directory was "/", which is not my

I tried to cat out /etc/passwd, but there was no "passwd" (or "groups") in
/etc . I looked at the output of "env", and it does say that HOME is "/".

When I saw this behavior, I tried rebooting again just in case, but it
didn't change.  I guess I'm going to try running the cygwin installer to
see if it will repair itself. I have no idea whether it would do that.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply via email to