windows event log does contain something, but I can't understand them.
"The description for Event ID ( 0 ) in Source ( cron ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: cron : PID 3248 : `cron' service stopped.".

I don't know how to search "at /interactive" on "cygwin.com". In cygwin.com, no search engine is provided.


Igor Pechtchanski wrote:


Does the Windows event log contain any clues?

Cron from the command line wouldn't start a service -- it'll start the
application itself...  Which should be enough to ascertain whether your
crontab works.

The instructions for getting a system-owned shell can easily be found by
searching Google for "system-owned shell cygwin".

On Tue, 30 Sep 2003, Chunyu Liu wrote:


Thank you for the help.

I tried to follow your instruction, but no luck to get it work.
1. cron_diagnosis.sh does not find any problem.
2. the cygcheck is attached.
3. The only error message I got is:

$ cygrunsrv --start cron
cygrunsrv: Error starting a service: QueryServiceStatus: Win32 error 1062:
The service has not been started.

4. cron.log is fine.

[1732] cron started
[1652] cron started
[1920] cron started
[3668] cron started
[264] cron started
[3668] cron started
[2284] cron started

5. cron from the command line  looks fine, does not report any error,
but does not start the service either.

6. How to get the SYSTEM-owned shell?

I've spent hours trying to find the answer to all the problems in the
sea of questions & answers, and can't make it.
It's really a headache.


Igor Pechtchanski wrote:

>Please do not send Cygwin questions in personal mail unless specifically
>requested. All discussion of cygwin-related topics should happen on the
>Cygwin list unless specifically requested otherwise. One of the benefits
>is that the discussion ends up in the list archives. Another is that you
>have access to the expertise of many people instead of just one.
>For your convenience, I'm redirecting this query to the Cygwin list. More
>replies below.
>On Mon, 29 Sep 2003, Chunyu Liu wrote:
>>Dear Igor Pechtchanski,
>>I noticed that you've been trying discussed this problem in the forum.
>>But I don't know whether you had the conclusion on this.
>>Would you mind helping me?
>>I have tried
>>cygrunsrv -I cron -p /usr/sbin/cron -a -D
>>cygrunsrv -S cron
>>and set /var/run/cron.pid to a+rw,
>>At the "-S cron" step, I can even see the new record in the log file at
>>/var/log, saying
>>[1652] cron started
>>But cygwin pompts:
>>"cygrunsrv: Error starting a service: QueryServiceStatus: Win32 error 1062:
>>The service has not been started."
>>And "ps" does not show job of cron running. The cron does not do any
>>scheduled work either.
>>I checked Windows Services control panel, the cron is associated with
>>cygrunsrv there. But whenever it's "started", it stopped immediately.
>>Any help would be greatly appreciated!
>>Chunyu Liu
>Is there any information in the log on why the cron program couldn't run?
>Can you run cron from the command line? ...From a SYSTEM-owned shell?
>Did you search the list archives for a similar problem? Did you run Mark
>Harig's "cron_diagnose.sh"?
>Also, please read and follow the Cygwin problem reporting guidelines at
> Igor

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply via email to