On Mon, Aug 11, 2008 at 01:59:56PM -0700, Jason Dagit wrote: > David, > > I didn't forget about the other comments you had, like removing dropWhile*, > but did you have a chance to look this over? I've been assuming you like > this version just fine and doing the rest of my work on top of it. So if it > still needs refinement it would be nice to know.
Yeah, I think this is already applied. I must have forgotten to reply. > Also, the setTentativePending and prepend that I mentioned are not export > from Internal and could be renamed unsafeSetTentativePending and > unsafePrepend until we have a chance to make them safe. But, I think they > are a relatively small part of the overall process and can wait, at least > for now. Right, and that is good. As long as they're not exported it's not very serious. You're right that renaming them would be best (to prevent someone from exporting them later), but it's definitely not urgent. > Thanks, > Jason > > On Sat, Aug 9, 2008 at 10:24 PM, Jason Dagit <[EMAIL PROTECTED]> wrote: > > > David, > > > > This is a resend of my type witnesses in the repository internals after > > looking at your feedback. Maybe we can do better for setTentativePending > > and prepend, but nothing comes to mind at the moment. > > > > Thanks, > > Jason > > > > Thu Aug 7 18:53:43 PDT 2008 Jason Dagit <[EMAIL PROTECTED]> > > * Make Darcs.Repository.Internal compile with type witnesses. > > > > Sat Aug 9 22:11:09 PDT 2008 Jason Dagit <[EMAIL PROTECTED]> > > * improve type safety of Darcs.Repository.Internal. > > > > -- David Roundy Department of Physics Oregon State University _______________________________________________ darcs-users mailing list [email protected] http://lists.osuosl.org/mailman/listinfo/darcs-users
