# News and discussions

1.  Since the first release of Darcs 2.12, we released a few minor versions,
    the latest being 2.12.5 on January:

    -   <https://hackage.haskell.org/package/darcs-2.12.5/changelog>

2.  Ben Franksen performed some refactorings about Darcs (zsh) autocompletion:

    -   
<https://hub.darcs.net/darcs/darcs-reviewed/patch/4800ed861b90e94d6963ba9079725d7e6cdddeda>
    -   
<https://hub.darcs.net/darcs/darcs-reviewed/patch/4ddee01dac242abaed1d532c94f9a105bec7f272>
    -   
<https://hub.darcs.net/darcs/darcs-reviewed/patch/ad82b9f4b110df2924e1fa1fb6074c48a2cf6234>

2.  As for Darcsden, the backend of <http://hub.darcs.net>, progress has been
    made on modernizing the ssh server used by it:

    -   <https://hub.darcs.net/ganesh/ssh/issue/5>
    -   <https://hub.darcs.net/simon/darcsden>

# Issues resolved (7)

issue2138 Guillaume Hoffmann
  ~ -   report conflicting files in whatsnew -s
    -   <http://bugs.darcs.net/issue2138>

issue2496 Ben Franksen
  ~ -   improve output of darcs whatsnew with file arguments
    -   <http://bugs.darcs.net/issue2496>

issue2498 Ganesh Sittampalam
  ~ -   unconditionally use the Haskell HTTP package
    -   <http://bugs.darcs.net/issue2498>

issue2504 Ben Franksen
  ~ -   skip ssh tests that require password input
    -   <http://bugs.darcs.net/issue2504>

issue2512 Stephan-A. Posselt
  ~ -   author name is written to repository after multiple-choice prompt
    -   <http://bugs.darcs.net/issue2512>

issue2516 Ben Franksen
  ~ -   joining (possible) URL path elements should not use `</>` from
System.FilePath
    -   <http://bugs.darcs.net/issue2516>

issue2526 Ben Franksen
  ~ -   actually consider boring option in D.UI.Flags.diffingOpts
    -   <http://bugs.darcs.net/issue2526>


# Patches applied (196)

2017-04-20 Ben Franksen
  ~ -   whatsnew: fixed wrong use of term hunk in help texts and comments
    -   fixed haddocks for FreeRight
    -   harness: honor failing- prefix for network tests just as for shell tests

2017-04-14 Ganesh Sittampalam
  ~ -   remove some impredicativity in the test harness

2017-04-01 Gian Piero Carrubba
  ~ -   Miscellaneous minor cleanups

2017-03-31 Ben Franksen
  ~ -   fixed type option argument to --siblings
    -   cleanup imports in diff command
    -   removed all help options
    -   remove --overview option, add -V as --version alias
    -   zsh completion: suppress possible error messages with --list-options
    -   removed unused option reorderPatches (all commands use option 'reorder')
    -   add class YesNo and instances to Darcs.Options.All
    -   more option renaming: askdeps->askDeps, workingRepoDir->repoDir

2017-03-28 Ben Franksen
  ~ -   refactor: replace all trivial functions in D.UI.Flags with re-exports
    -   fix handling of parse errors for --max-count option
    -   renamed option xmloutput to xmlOutput
    -   added infix operator (?) as synonym for parseFlags
    -   remove flag list manipulation from show {authors, repo}
    -   cleaned up pull command

2017-03-08 Gian Piero Carrubba
  ~ -   Accept issue2275: darcs follows symbolic links instead of ignoring them

2017-03-28 Ben Franksen
  ~ -   cleanup of Darcs.UI.Options "master" module
    -   cleaned up obsolete comment in Darcs.UI.Options.All
    -   renamed hasXmlOutput to xmlOutput, hasXmlOutput returns Bool
    -   rename (amQuiet,amVerbose) to (quiet,verbose), move to
D.UI.Flags, and export
    -   re-write of zsh completion script
    -   use knownFileArgs, not noArgs, for show files
    -   complete files for darcs replace only if 2 args are already present
    -   refactored shell completion support
    -   refactored repair/check command
    -   remove files and directories options from commands that don't use them
    -   show repo: fixed excessively borked code indentation
    -   removed mention of --files from help text for show repo command
    -   show repo: removed --files option, removed manual flags parsing
    -   fix warning in harness/Storage/Hashed/Test.hs
    -   show repo: fixed formatting (boringfile Pref overflowed alignment)
    -   add patch index status to show repo command
    -   annotate/options: allow --human-readable to counter --machine-readable

2017-04-07 Guillaume Hoffmann
  ~ -   remove outdated directory_confusion.sh
    -   remove unused toolbox.sh test

2017-03-22 Ben Franksen
  ~ -   simplified implementation of Darcs.UI.Options.All.dryRun
    -   refactor: add data type for hook options
    -   refactor: move usage and help related functions from
Darcs.UI.Commands to Darcs.UI.Usage
    -   refactor: moved printDryRunMessageAndExit from
Darcs.UI.Commands to Darcs.UI.Commands.Util
    -   refactor: help and usage formatting cleanup
    -   improved haddocks for Darcs.Util.Printer
    -   remove umask and update_working parameters from withRepoLockCanFail
    -   fixed Darcs.Util.Printer.vsep by folding over a new binary
operator vplus
    -   removed Darcs.Util.Environment: we require base >= 4.8 anyway
so just use lookupEnv
    -   add cabal.project.local (created by cabal new-configure) to .boring
    -   tests/log.sh: run tests in separate dirs and don't remove them
    -   fixed typo in option help for --no-pending

2017-03-20 Ganesh Sittampalam
  ~ -   add some more test cases of command-line substitution
    -   move some tests from documentation to the actual test harness

2017-03-15 Ben Franksen
  ~ -   resolve issue2526: actually consider boring option in
D.UI.Flags.diffingOpts
    -   accept issue2526: whatsnew -l --boring should list boring files

2017-03-15 Gian Piero Carrubba
  ~ -   bash_completion: copy the approach used by the zsh completion
    -   bash_completion: better support for multi-level commands

2016-11-02 Timo von Holtz
  ~ -   fix mail encode with '.' or '=' as last character

2017-02-26 Ben Franksen
  ~ -   fixed a todo comment regarding email encoding
    -   add roundtrip property for email MIME codec and a unit test
    -   resolve issue2504: skip ssh tests that require password input

2016-09-29 Guillaume Hoffmann
  ~ -   introduce withOldRepoLock, reduce code specific to old-fashioned repos
    -   save lines in D.R.Hashed
    -   remove a useless forall in D.R.Pending
    -   remove useless language extensions in Darcs.Repository modules
    -   remove a few useless foralls
    -   rename Darcs.Repository.Internal to Darcs.Repository.Identify
    -   move hashed related functions from Internal to Hashed
    -   move repoPatchType from Internal to InternalTypes
    -   create Repository.Working
    -   move merge related functions from Internal to Merge
    -   move pending related functions from Internal to Pending
    -   rename Darcs.Repository.HashedRepo to Darcs.Repository.Hashed

2017-03-08 Gian Piero Carrubba
  ~ -   Fix `'optimize <subcommand> --list-options'`

2016-12-20 Ben Franksen
  ~ -   resolve issue2516: joining (possible) URL path elements should
not use `</>` from System.FilePath

2017-01-10 Ganesh Sittampalam
  ~ -   support vector 0.12
    -   support directory 1.3
    -   support HUnit 1.4 and 1.5
    -   support time 1.7
    -   add IsRepoType constraint to the PrimV1Job type

2016-10-18 Stephan-A. Posselt
  ~ -   resolve issue2512: author name is written to repository after
multiple-choice prompt
    -   added regression test for issue2512

2016-09-29 Guillaume Hoffmann
  ~ -   typo in test oldfashioned.sh
    -   remove show bug test
    -   merge Motd module into Prefs
    -   remove show bug hidden command
    -   delete outdated script run-all-tests
    -   merge two tests into revert.sh
    -   merge one add test into add.sh
    -   rollback template haskell hack since we use cabal >= 1.18
    -   bump cabal dependency to 1.22.5 and remove workaround in cabal file
    -   bump dependencies following haskell platform 7.10.3
    -   mark comment as TODO
    -   really fix compilation under Windows
    -   resolve issue2510: import Control.Exception even under Windows
    -   changelog entries for 2.12.1 and 2.12.2
    -   add missing sshlib import to test
    -   no longer print darcs version in output of help markdown
    -   resolve issue2507: add tests/network/sshlib to extra-sources-files

2016-08-31 Ganesh Sittampalam
  ~ -   improve error message when library ends up unbuildable
    -   bump QuickCheck dependency
    -   resolve issue2498: unconditionally use the Haskell HTTP package

2016-05-06 Ben Franksen
  ~ -   added regression test for issue2496
    -   resolve issue2496: improve output of darcs whatsnew with file arguments
    -   fix in record: use only existing file arguments when querying patches

2016-05-05 Ganesh Sittampalam
  ~ -   silence the GHC 8.0 redundant constraints warning for now
    -   remove unused class member 'maybeWork' from ParserM
    -   remove unused class member 'toChar' from Darcs.Util.Path.CharLike
    -   remove unused class member 'toFL' from Darcs.Patch.Non.WL

2016-07-02 Sergei Trofimovich
  ~ -   Tweak for sandi-0.4.*

2016-09-01 Guillaume Hoffmann
  ~ -   require GHC 7.10 and time 1.5
    -   merge show contents tests
    -   merge diff tests
    -   remove trivial test justrm.sh
    -   merge one test into rmdir.sh
    -   delete rmdir-formerly-pl.sh subsumed by show_files.sh
    -   merge two tests into record.sh
    -   merge one test into clone.sh
    -   merge init tests
    -   merge annotate tests
    -   merge rollback tests
    -   merge apply tests
    -   merge tag tests
    -   merge repair and check tests
    -   merge oldfashioned tests
    -   remove unclear nfs-failure.sh test
    -   merge clone tests
    -   bump version to 2.13.0
    -   TAG 2.12.0
    -   remove -prof flags from darcs.cabal
    -   do not pass rts flag for library
    -   remove hpc flag since cabal supports it since 2015
    -   2.12 changelog
    -   move runHLint.sh to contrib and add to darcs.cabal
    -   bump version to 2.12.0
    -   consistently use 'working tree' phrase
    -   merge a test into optimize.sh
    -   merge tests into log.sh and rename changes to log
    -   consolidate push shell tests
    -   consolidate pull shell tests
    -   consolidate add shell tests
    -   improve issue1825 test
    -   consolidate remove shell tests
    -   consolidate unrecord shell tests
    -   consolidate mv shell tests
    -   consolidate record shell tests
    -   consolidate unrevert shell tests
    -   rename changes tests to log and consolidate
    -   consolidate amend shell tests into one
    -   consolidate dist shell tests into one
    -   consolidate replace shell tests into one
    -   consolidate whatsnew shell tests into one
    -   consolidate obliterate shell tests into one
    -   merge UI.RemoteApply into UI.Commands.Push
    -   remove support for DARCS_GET_ and DARCS_APPLY_ hacks
    -   fix failing-merging_newlines.sh
    -   fix failing-issue2293
    -   rm failing-issue2238 wrongly failing and fixed anyway
    -   add lib import to test
    -   fix issue1702 test and accept issue as resolved
    -   fix failing-issue1316
    -   remove failing-issue1013 tests as not interesting
    -   remove annotate --index form failing-index test

2016-02-28 Ganesh Sittampalam
  ~ -   support base-4.9 (GHC 8.0)
    -   add type signature needed for GHC 8.0
    -   add pragma needed for GHC 8.0

2016-04-21 Guillaume Hoffmann
  ~ -   update messages in Darcs.Patch.Match
    -   reduce help of init
    -   mention weak hash in help of show repo
    -   update help of diff
    -   reduce help of push
    -   reduce help of pull
    -   reduce help of clone
    -   reduce help of record
    -   darcs help: new sections and order for commands
    -   remove all hidden aliases of show, deprecated for years
    -   make some command descriptions shorter and nicer
    -   merge all show patch-index commands into one
    -   hlint Darcs.UI.Commands.Convert
    -   hlint Darcs.UI.Commands.Optimize
    -   hlint Darcs.Util.Ssh
    -   hlint Darcs.Util.Tree*
    -   remove unnecessary pragma in Darcs.Util.Exception
    -   remove unnecessary pragma in Darcs.UI.Command.Record
    -   remove unnecessary pragma in Darcs.UI.Command.Convert
    -   remove unnecessary pragma in Darcs.UI.Command.Apply
    -   remove unnecessary pragmas in Darcs.Repository.Rebase
    -   remove unnecessary pragma in Darcs.Patch.Rebase.Container
    -   remove unnecessary pragma and do in Darcs.Patch.Named.Wrapped

2016-04-21 Ganesh Sittampalam
  ~ -   add a couple of missing upper bounds
    -   add traverse to Darcs.Prelude to fix build on GHC 7.6

2016-04-08 Guillaume Hoffmann
  ~ -   resolve issue2138: report conflicting files in whatsnew -s
    -   move local functions of getMovesPs closer to where used
    -   reimplement resolution of --look-for-moves and update tests
    -   fix and clarify getReplaces
    -   fix a network test after annotate patch feature removal
_______________________________________________
darcs-users mailing list
darcs-users@osuosl.org
https://lists.osuosl.org/mailman/listinfo/darcs-users

Reply via email to