Did you check line 39 in selection_to_pdf.lua?

39 dt.configuration.check_version(...,{2,0,0},{3,0,0},{4,0,0},{5,0,0})


Am 07.03.2018 um 11:01 schrieb David Vincent-Jones:
After making the git update some items (gimp for instance) are now
functioning correctly and I have moved the 'unresponsive' items to the
bottom of the list.

The error message however still appears as it was before indicating a
version mismatch:

LUA ERROR API Version: 5.0.0
LUA ERROR : /home/david/.config/darktable/lua/selection_to_pdf.lua:39:
Module selection_to_pdf is not compatible with API 5.0.0

I have checked that all the listed requirments are correctly in place
What am I still missing?

David


On 03/06/2018 09:59 PM, William Ferguson wrote:
The easiest way, IMHO, to get the scripts and keep them up to date is

cd ~/.config/darktable
git clone https://github.com/darktable-org/lua-scripts.git
mv lua-scripts lua

Then, when you want to update

cd ~/.config/darktable/lua
git pull


Regards,

Bill

On Tue, Mar 6, 2018 at 3:41 PM, August Schwerdfeger
<aug...@schwerdfeger.name <mailto:aug...@schwerdfeger.name>> wrote:

     All of one's Lua scripts can be disabled by a single Lua error, so I
     would try updating to the current version of the
     'selection_to_pdf.lua' script.

     --
     August Schwerdfeger
     aug...@schwerdfeger.name <mailto:aug...@schwerdfeger.name>

     On Tue, Mar 6, 2018 at 2:00 PM, David Vincent-Jones
     <david...@gmail.com <mailto:david...@gmail.com>> wrote:

         This is the cl feedback .... there is no mention of the gimp.lua
         I am currently showing Lua version as 5.3.4 ... appears to be
         the latest.

         david@carbon:~> darktable -d lua
         [imageop_init_presets] updating 'basecurve' preset 'fujifilm
         like' from
         version 4 to version 5
         LUA ERROR API Version: 5.0.0
         LUA ERROR :
         /home/david/.config/darktable/lua/selection_to_pdf.lua:39:
         Module selection_to_pdf is not compatible with API 5.0.0

         David

         On 03/06/2018 03:40 PM, Patrick Shanahan wrote:
         > * David Vincent-Jones <david...@gmail.com 
<mailto:david...@gmail.com>> [03-06-18 09:28]:
         >> For some reason my Lua scripts are not showing as export options.
         >>
         >> With Gimp (for example) the 'require "official/gimp" ' entry does 
exist
         >> and is correctly located in the ~/.config/darktable/luarc file.  
None of
         >> the other Lua options are also showing.  ....  What am I missing?
         >
         > did you start dt from the cl to see what you are missing?
         >   darktable -d lua
         >
         >
         
____________________________________________________________________________
         darktable user mailing list
         to unsubscribe send a mail to
         darktable-user+unsubscr...@lists.darktable.org
         <mailto:darktable-user%2bunsubscr...@lists.darktable.org>



     
____________________________________________________________________________
     darktable user mailing list to unsubscribe send a mail to
     darktable-user+unsubscr...@lists.darktable.org
     <mailto:darktable-user%2bunsubscr...@lists.darktable.org>



____________________________________________________________________________
darktable user mailing list to unsubscribe send a mail to
darktable-user+unsubscr...@lists.darktable.org
____________________________________________________________________________
darktable user mailing list
to unsubscribe send a mail to darktable-user+unsubscr...@lists.darktable.org


____________________________________________________________________________
darktable user mailing list
to unsubscribe send a mail to darktable-user+unsubscr...@lists.darktable.org

Reply via email to