* Dave Rolsky ([EMAIL PROTECTED]) [21 Mar 2003 15:14]: > On Fri, 21 Mar 2003, Iain 'Spoon' Truskett wrote: [...] > > Well, any format that has two digit years. Still, abolished.
> Yeah, but others may treat 0-79 as 2000 and 80-00 as 1900, and so on. > That was what was too specific. Do the simplest first =) I became distracted by lunch and didn't finish the email properly. I was going to say that were it to remain it would naturally have some sort of configuration. But at that point it's getting complicated and is best off excised. [snip "on_match callback as post-processor"] > > Hmm. Yes. No. Yes. No. I'd like for on_match to be able to happen > > without having to return anything. > Ok, but it seems like some sort of post-processing feature might be > good. Yes. I've been contemplating handing it a hashref and letting it modify that if it so desires (which is where 0.23 is at presently). Not sure if that's too much of a 'hidden' action. > > Bare in mind that 0.22 was just what I wrote before any sort of > > refactoring. [...]. That said, I happily accept your criticism. > That's cool. That's what code review's for, right? ;) Absolutely! > One more thing. I think the create_class method should simply use the > package name of its caller, rather than take one explicitly, and > should probably be renamed "create_methods". It's going to be used by > format module writers who'll do: > package DateTime::Format::Gobbledygook; > use DateTime::Format::Builder; > DateTime::Format::Builder->create_methods( ... ); Much what I was thinking. I do enjoy how Class::DBI operates, but didn't want the inheritance part. What you have there seems the most appropriate. Thanks again =) cheers, -- Iain.
