Hello,
Having had a second look at your example (comparing with what I've used
here), I think it might make sense to change it a bit:
Am 01.03.2014 14:10, schrieb Alexander Holler:
> Am 28.02.2014 14:51, schrieb Prabhakar Lad:
>> +leds {
pinctrl-names = "default";
pinctrl-0 = <&led_pins>;
>> + compatible = "gpio-leds";
>> + led1 {
>> + label = "davinci:green:usr1";
>> + gpios = <&gpio0 10 GPIO_ACTIVE_HIGH>;
linux,default-trigger = "heartbeat";
>> + };
>> +
>> + led2 {
>> + label = "davinci:red:debug1";
>> + gpios = <&gpio0 11 GPIO_ACTIVE_HIGH>;
>> + };
>> +};
or just add "..." to denote that there should/might be some additional
stuff which doesn't really belong to the description of the gpio-binding
(like pinctrl).
Regards,
Alexander Holler
_______________________________________________
Davinci-linux-open-source mailing list
Davinci-linux-open-source@linux.davincidsp.com
http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source