Il giorno mar, 22/01/2008 alle 15.48 +0700, Stuart Bishop ha scritto:
> 
> I'm happy with the design.
> 
I am very happy too, but..
> 
> I would think the following would be better names:
>     con.begin_prepared(xid=None)
>     con.prepare_transaction()
>     con.rollback_prepared(xid=None)
>     con.commit_prepared(xid=None)
>     con.list_prepared()

I don't like "prepared" because can be interpreted as "prepared
transaction" as as "prepared statement". I'd like something that won't
confuse users. I agree that xa is too specific. That leaves us with the
long prepared_transaction or something generic like twophase (or 2pc or
tpc_prefix, or?)

begin_prepared_transaction()
prepare_transaction()
rollback_prepared_transaction()
...

begin_2pc_transaction()
prepare_2pc_transaction()
rollback_2pc_transaction()
...

begin_twophase()
prepare_twophase()
rollback_twophase()
...

tpc_begin()
tpc_prepare()
tpc_rollback()

federico

-- 
Federico Di Gregorio                         http://people.initd.org/fog
Debian GNU/Linux Developer                                [EMAIL PROTECTED]
INIT.D Developer                                           [EMAIL PROTECTED]
              All programmers are optimists. -- Frederick P. Brooks, Jr.

Attachment: signature.asc
Description: Questa รจ una parte del messaggio firmata digitalmente

_______________________________________________
DB-SIG maillist  -  DB-SIG@python.org
http://mail.python.org/mailman/listinfo/db-sig

Reply via email to