Hi Galimov, Thanks for DBD::Pg::hstore, it looks interesting. However, I think the name isn’t great. There is nothing DBD::Pg specific about it, is there? You just have the decode() and encode() functions that take strings, yes?
If so, I think a better name might be Pg::Hstore (or Pg::hstore if you prefer). I also suggest giveing the exported functions longer names, like encode_hstore() and decode_hstore(), to prevent conflicts with, e.g., the Encode module. Looking forward to giving your module a try. Thank you! Best, David