You are getting this error because the installation path that you specified 
is not valid.
When you did you cmake command, you specific the installation path to :  
This path on your linux machine is not a valid path, and consequently, this 
folder cannot be created.
You need to run cmake again and specify a valid installation path 
(something like /home/your_user/dealii/ for instance).
You are very close to getting it to fully compile :)


On Sunday, 7 June 2020 09:54:39 UTC-4, Wilmar Alves Cruvinel Lima wrote:
> I tried to install Deal II (dealii) on a PC with 2 GB RAM, but after the 
> command:
> wilmar@linuxmint:~build$ *make --jobs=1 install  *(jobs=4 was bad)  it 
> stops on     [ 31%] Building CXX object 
> source/fe/CMakeFiles/obj_fe_release.dir/fe_q.cc.o.
> So, I tried on another PC with 4 GB RAM. It builds CXX object until 100%:
> ...
> [100%] Building CXX object 
> source/non_matching/CMakeFiles/obj_non_matching_debug.dir/immersed_surface_quadrature.cc.o
> [100%] Built target obj_non_matching_debug
> Scanning dependencies of target deal_II.g
> [100%] Building CXX object source/CMakeFiles/deal_II.g.dir/dummy.cc.o
> [100%] Linking CXX shared library ../lib/libdeal_II.g.so
> [100%] Built target deal_II.g
> Scanning dependencies of target obj_integrators_debug
> [100%] Built target obj_integrators_debug
> Scanning dependencies of target obj_integrators_release
> [100%] Built target obj_integrators_release
> Scanning dependencies of target obj_rol_inst
> [100%] Built target obj_rol_inst
> Scanning dependencies of target obj_rol_release
> [100%] Built target obj_rol_release
> Scanning dependencies of target obj_rol_debug
> [100%] Built target obj_rol_debug
> but, there is a fly in the ointment. I proceeds:
> Install the project...
> -- Install configuration: "DebugRelease"
> CMake Error at cmake/scripts/cmake_install.cmake:41 (file):
>   file cannot create directory: /path/to/install/dir/share/deal.II/scripts.
>   Maybe need administrative privileges.
> Call Stack (most recent call first):
>   cmake_install.cmake:42 (include)
> Makefile:73: recipe for target 'install' failed
> make: *** [install] Error 1
> The command did not manage to create the directoty  
> */path/to/install/dir/share/deal.II/scripts*
> I feel that I crossed the ocean and died on the beach!   but the cause 
> wasn't n-Cov19!
> Any help?

The deal.II project is located at http://www.dealii.org/
For mailing list/forum options, see 
You received this message because you are subscribed to the Google Groups 
"deal.II User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to dealii+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to