On 7/28/20 11:05 AM, Muhammad Mashhood wrote:

/.~/working_dir/step-42$ /step-42 p1_chinese.prm
Segmentation fault (core dumped)/

I tried to comment out the line "  , particle_handler(triangulation, mapping, /*n_properties=*/dim) " and by doing so the code starts running normally.

I have tried to run it in the debug mode but over there the program exits with following error:

/(gdb) r
Starting program: ~/working_dir/step-42/step-42
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
*** Call this program as <./step-42 input.prm>

You need to run the executable with
  r p1_chinese.prm
to make sure it loads the appropriate input file, or you will not see the segmentation fault in the debugger.


[Inferior 1 (process 5082) exited with code 01]/

Can there be a possible problem in using the " /particle_handler(triangulation, mapping, /*n_properties=*/dim) /" ? Thank you!

I don't know. Can you get a backtrace in the debugger?

It's something that ought to work. If you can't figure out what is happening, send me the exact .cc file you're trying to run and I'll take a look!

Best
 W.

--
------------------------------------------------------------------------
Wolfgang Bangerth          email:                 bange...@colostate.edu
                           www: http://www.math.colostate.edu/~bangerth/

--
The deal.II project is located at http://www.dealii.org/
For mailing list/forum options, see 
https://groups.google.com/d/forum/dealii?hl=en
--- You received this message because you are subscribed to the Google Groups "deal.II User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to dealii+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/dealii/9d6e7acb-3b71-ee27-c819-062e7c77e4aa%40colostate.edu.

Reply via email to