Source: apr-util
Version: 1.5.4-2
Severity: minor
Tags: patch
User: helm...@debian.org
Usertags: rebootstrap
Control: affects 794103 + src:apr-util

apr-util cannot satisfy its cross Build-Depends:
 * The host architecture binutils is requested, but it conflicts with
   the build architecture binutils, which is requested by
   build-essential. Since build-essential already ensures availability
   of binutils for both architectures, we can simply drop it.
 * The host architecture python is requested, but it can neither be
   installed nor executed. As it is really used as a build tool,
   annotate its dependency with :any.

After applying the attached patch, apr-util still fails to cross build
from source, because it is affected by #794103.

Helmut
diff --minimal -Nru apr-util-1.5.4/debian/changelog 
apr-util-1.5.4/debian/changelog
--- apr-util-1.5.4/debian/changelog     2016-07-14 12:00:56.000000000 +0200
+++ apr-util-1.5.4/debian/changelog     2016-10-15 21:12:10.000000000 +0200
@@ -1,3 +1,12 @@
+apr-util (1.5.4-2.1) UNRELEASED; urgency=medium
+
+  * Non-maintainer upload.
+  * Fix unsatisfiable cross Build-Depends: (Closes: #-1)
+    + Drop binutils from Build-Depends as it is build-essential.
+    + Annotate Build-Depends: python with :any.
+
+ -- Helmut Grohne <hel...@subdivi.de>  Sat, 15 Oct 2016 21:11:45 +0200
+
 apr-util (1.5.4-2) unstable; urgency=medium
 
   [ Jean-Michel Vourgère ]
diff --minimal -Nru apr-util-1.5.4/debian/control apr-util-1.5.4/debian/control
--- apr-util-1.5.4/debian/control       2016-07-14 11:58:27.000000000 +0200
+++ apr-util-1.5.4/debian/control       2016-10-15 21:12:25.000000000 +0200
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian Apache Maintainers <debian-apache@lists.debian.org>
 Uploaders: Stefan Fritsch <s...@debian.org>, Peter Samuelson <pe...@p12n.org>
-Build-Depends: debhelper (>> 9~), autoconf, autotools-dev, mawk, libldap2-dev, 
libexpat1-dev, libdb-dev, libpcre3-dev, binutils, libapr1-dev (>> 1.4.8-2~), 
libsqlite3-dev, libpq-dev, python, libmysqlclient-dev, unixodbc-dev, doxygen, 
libssl-dev
+Build-Depends: debhelper (>> 9~), autoconf, autotools-dev, mawk, libldap2-dev, 
libexpat1-dev, libdb-dev, libpcre3-dev, libapr1-dev (>> 1.4.8-2~), 
libsqlite3-dev, libpq-dev, python:any, libmysqlclient-dev, unixodbc-dev, 
doxygen, libssl-dev
 Standards-Version: 3.9.8
 Vcs-Browser: https://anonscm.debian.org/cgit/pkg-apache/apr-util.git
 Vcs-Git: git://anonscm.debian.org/pkg-apache/apr-util.git

Reply via email to