Package: flash-kernel
Version: 3.79
Severity: critical
Justification: breaks the whole system

Dear Maintainer,

I have been running Debian on a QNAP TS109 for many years.
I successfully upgraded from Squeeze to Wheezy in 2013 and to Jessie in 2015.

As I now upgrade to Stretch (basically following Debian Upgrade Guide, it
is a very simple system) I now get:

== from apt-get dist-upgrade ==
update-initramfs: Generating /boot/initrd.img-4.9.0-5-marvell
flash-kernel: installing version 4.9.0-5-marvell

The initial ramdisk is too large. This is often due to the unnecessary inclusion
of all kernel modules in the image. To fix this set MODULES=dep in one or both
/etc/initramfs-tools/conf.d/driver-policy (if it exists) and
/etc/initramfs-tools/initramfs.conf and then run 'update-initramfs -u
-k 4.9.0-5-marvell'

Not enough space for initrd in MTD 'RootFS1' (need 4210887 but is
actually 4194304).
run-parts: /etc/initramfs/post-update.d//flash-kernel exited with return code 1
dpkg: error processing package initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
== end of output

That was (obviously) after
 - editing /etc/apt/sources.list (changing jessie to stretch)
 - apt-get update
 - apt-get upgrade

I am completely aware how old and obsolete this QNAP TS109 is.
It would make complete sense to me if it was not supported anymore.
And I would completely understand if you dont want to fix this problem.

But given that TS-109 appears supported
and with no major issues
I would not expect this problem well into the upgrade.

To other users, it would be helpful to advice them not to upgrade to Stretch.

I guess my system would reboot if I try (but I have not tried)
I guess Debain 9.3 can run with Linux 3.16.0-5-orion5x from Debian 8, but
to me (I have used Debian for 20 years) the system seems to be in a rather
bad state. (if it fails to boot a serial cable for direct UBOOT is necessary)

I have not tried editing

I suppose i could try to change MODULES=most to MODULES=dep.

However, if I break the system completely it will be much harder for me
to give you any more useful information.

  Best Regards
  Gunnar Thorburn

-- System Information:
Debian Release: 9.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: armel (armv5tel)

Kernel: Linux 3.16.0-5-orion5x
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8),
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages flash-kernel depends on:
ii  debconf [debconf-2.0]  1.5.61
ii  devio                  1.2-1.2+b1
ih  initramfs-tools        0.130
ii  linux-base             4.5
ii  mtd-utils              1:2.0.0-1
ii  ucf                    3.0036

Versions of packages flash-kernel recommends:
ii  u-boot-tools  2016.11+dfsg1-4

flash-kernel suggests no packages.

-- debconf information:
  flash-kernel/linux_cmdline: quiet

Reply via email to