Hi,

Creating this file with COMPRESS=xz worked fine
/etc/initramfs-tools/conf.d/compress

Obviously, with xz there is plenty of space left. There was a little
warning though (see below).

Generating kernel u-boot image... done.
Flashing kernel (using 2050440/2097152 bytes)... done.
Flashing initramfs (using 2870792/4194304 bytes)... done.
W: APT had planned for dpkg to do more than it reported back (0 vs 7).
   Affected packages: flash-kernel:armel initramfs-tools:armel


Yes, this system has been upgraded several time. I think your web page
even said that that is the correct/only way to do it.

I guess installing Stretch does COMPRESS=xz on its own.

Thank you so much. My problem is now solved. But perhaps xz could be
part of the upgrade process.

On 12 February 2018 at 22:05, Gunnar Thorburn <gunnar.thorb...@gmail.com> wrote:
> Hi Martin,
>
> I sincerely apologize for setting the wrong severity to the wrong
> package in the original report.
> (I thought the system could be in a state where it would not reboot at all)
>
> I am sorry to inform you that changing to MODULES=dep in
> initramfs.conf did not help.
> (driver-policy already had MODULES=dep).
>
> And no, I am not using LVM or RAID (just a standard ext2-partitions
> for /, /boot, /home/ and one for swap on a single SATA drive).
>
> The good thing is that the system reboots properly and seems to work
> fine with the old 3.16 kernel.
>
> There is no
> /etc/initramfs-tools/conf.d/compress
>
> I will try it out and get back.
>
> Thank you very much!
>
>
>
>
>
> On 12 February 2018 at 21:57, Martin Michlmayr <t...@cyrius.com> wrote:
>> Unfortunately my memory is quite bad.  I *thought* the current
>> installer configured XZ compression by default but it seems that's not
>> the case.  So the documentation on my web site is correct.
>>
>> * The installer sets MODULES=dep
>> * It has done so for a long time
>> * But you've upgraded from a really old release where this wasn't the case 
>> (I believe)
>>
>> * The installer doesn't configure XZ compression
>> * You don't need it for a normal installation
>> * If you want LVM or RAID, you have to use XZ, as per the hint at 
>> http://www.cyrius.com/debian/orion/qnap/ts-109/known-issues/
>>
>> At least I *believe* that's the case.  I didn't investigate in detail.
>>
>> --
>> Martin Michlmayr
>> http://www.cyrius.com/

Reply via email to