Am 15.07.23 um 22:57 schrieb Pascal Hambourg:
> Replacing /lib/partman/init.d/50efi with either attached 50efi.1 or
> 50efi.2 as 50efi should fix the issue in guided partitioning with
> encrypted LVM.
>    cp <source path>/50efi.1 /lib/partman/init.d/50efi
> or
>    cp <source path>/50efi.2 /lib/partman/init.d/50efi

I tried each of them and they both solved my problem. /boot and /boot/efi were on the same (and correct) disk. The installed system was bootable :-)

> Fixing the issue in guided partitioning with unencrypted LVM also
> requires replacing /bin/autopartition-lvm with the attached
> autopartition-lvm.
>    cp <source path>/autopartition-lvm /bin/autopartition-lvm
> The files can be replaced after "Load installer components" and before
> "Partition disks".

I could reproduce the same issue with unencrypted LVM (#1034812) on my machine with my stock installer image.

Like above, replacing 50efi by 50efi.1 plus the other file in /bin made the installation work alright. The system was bootable afterwards.

Thanks a lot for the quick fixes!


Reply via email to