On Thu, Oct 05, 2006 at 06:06:55PM +0200, Frans Pop wrote:
> I've been meaning to provide more information (like logs from package 
> installation) on this and a specific, reproducible test case, but have 
> not found the time to do so.
> I'll try to do this and will send you the info when I do.


> Have you tried doing an installation yourself and seeing what happens?

I also had no time. I could not even test removing all dicts stuff and
reinstalling until yesterday. I also currently have no spare box for that,
so I had to try with qemu, and dedicate most of today to learn how to use
qemu with debian-installer and prepare an appropiate system.

I first downloaded a network d-i image, and installed it. Since I could not
yet make network work in that image I had to leave it with just the basic
installation, what is OK (no dicts at all). I then fetched the full DVD
first iso and set it as CD source, and simply did

# apt-get install iamerican ibritish ispanish 

That installed

dictionaries-common 0.70.2
ispanish            1.9-6

with *no prompts at all*.

Done in a 2GB qemu volume, single partition + swap, being ~1.5GB free
after installation, with american settings,

debian-installer/language: en
debian-installer/country: US

After installation, these are the ispell symlinks values

/etc/dictionaries-common/default.aff  -> /usr/lib/ispell/american.aff
/etc/dictionaries-common/default.hash -> /usr/lib/ispell/american.hash

as expected. If I install later some wordlists I am prompted (just once)
as expected because dictionaries-common is already installed.

However, when installing all the above dicts from the same run at the
first installation, everything works as expected with no prompts at all
and all the symlinks are correctly set.

Not tried with tasksel. I have not much time these days, so that might not
be inmediate. If in the meantime you or Christian reproduce the problem,
please, do not remove /var/cache/apt contents before looking at the
available space, with special care about the /var partition.
> > a) Does the problem you describe happens with wordlists too?
> _I_ have not seen it there, but that is probably because for en installs 
> _only_ the US wordlist is installed and not the GB one.

I think they should behave similarly, even when only a wordlist is installed
there are two options, it or manual, so the default must have been set
somewhere if there is no prompt.  

> > b) Is localization-config in use or not?
> No, it is not. As I've said before l-c is currently _not used_ during 
> installations _at all_, not for dictionaries, not for anything else.

Fine, this is clear now.

> > c) Does debian-installer still use debian-installer/{language,country}?
> Yes. And values for both are copied to the target system.
> debian-installer/language: en
> debian-installer/country: US

Thanks for the feedback. Will try to use tasksel and see if I can reproduce
the problem there.


with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]

Reply via email to