Your message dated Sat, 17 Sep 2016 13:08:06 +0100
with message-id <1474114086.2011.126.ca...@adam-barratt.org.uk>
and subject line Closing p-u bugs for updates in 8.6
has caused the Debian Bug report #827113,
regarding jessie-pu: package libquota-perl/1.7.1+dfsg-1+deb8u1
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
827113: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=827113
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: release.debian.org
Severity: normal
Tags: jessie
User: release.debian....@packages.debian.org
Usertags: pu

Hi SRM,

I would like to propose the attached debdiff for libquota-perl to be
able as well to build for stable if the underlying kernel is 4.x. It
was suggested by Dominic in #827101. 

There is not need to check for Linux 2.x, Linux 3.x or Linux 4.x, so
the test in Makefile.PL can be aligned with that what is done in
1.7.2+dfsg-1 (in unstable).

Fine to upload for jessie and be included in the next Jessie point
release?

Regards,
Salvatore
diff -Nru libquota-perl-1.7.1+dfsg/debian/changelog libquota-perl-1.7.1+dfsg/debian/changelog
--- libquota-perl-1.7.1+dfsg/debian/changelog	2013-10-23 13:30:45.000000000 +0200
+++ libquota-perl-1.7.1+dfsg/debian/changelog	2016-06-12 11:56:26.000000000 +0200
@@ -1,3 +1,11 @@
+libquota-perl (1.7.1+dfsg-1+deb8u1) jessie; urgency=medium
+
+  * Team upload.
+  * Adapt platform detection to work as well under Linux 4.x
+    (Closes: #787463, #827101)
+
+ -- Salvatore Bonaccorso <car...@debian.org>  Sun, 12 Jun 2016 11:55:10 +0200
+
 libquota-perl (1.7.1+dfsg-1) unstable; urgency=low
 
   * Team upload.
diff -Nru libquota-perl-1.7.1+dfsg/debian/patches/Adapted-platform-detection-for-Linux-4.x.patch libquota-perl-1.7.1+dfsg/debian/patches/Adapted-platform-detection-for-Linux-4.x.patch
--- libquota-perl-1.7.1+dfsg/debian/patches/Adapted-platform-detection-for-Linux-4.x.patch	1970-01-01 01:00:00.000000000 +0100
+++ libquota-perl-1.7.1+dfsg/debian/patches/Adapted-platform-detection-for-Linux-4.x.patch	2016-06-12 11:56:26.000000000 +0200
@@ -0,0 +1,20 @@
+Description: Adapted platform detection for Linux 4.*
+Origin: upstream
+Bug-Debian: https://bugs.debian.org/787463
+Bug-Debian: https://bugs.debian.org/827101
+Forwarded: not-needed
+Author: Salvatore Bonaccorso <car...@debian.org>
+Last-Update: 2016-06-12
+Applied-Upstream: 1.7.2
+
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -13,7 +13,7 @@ elsif($os =~ /^HP-UX (A\.09|B\.10|[BC]\.
+ elsif($os =~ /^IRIX 5/)    { $config='irix_5.h'; }
+ elsif($os =~ /^IRIX\d* 6/) { $config='irix_6.h'; }
+ elsif($os =~ /^OSF1/)      { $config='dec_osf.h'; }
+-elsif($os =~ /^Linux [23]/){ $config='linux.h'; $picobj='linuxapi.o'; }
++elsif($os =~ /^Linux/){ $config='linux.h'; $picobj='linuxapi.o'; }
+ elsif($os =~ /^GNU/)       { $config='gnu.h'; }
+ elsif($os =~ /^AIX/)       { $config='aix_4_1.h'; }
+ elsif($os =~ /^BSD\/OS 2/ ||
diff -Nru libquota-perl-1.7.1+dfsg/debian/patches/series libquota-perl-1.7.1+dfsg/debian/patches/series
--- libquota-perl-1.7.1+dfsg/debian/patches/series	2013-10-23 13:30:45.000000000 +0200
+++ libquota-perl-1.7.1+dfsg/debian/patches/series	2016-06-12 11:56:26.000000000 +0200
@@ -1 +1,2 @@
 02_gnu_hurd.patch
+Adapted-platform-detection-for-Linux-4.x.patch

--- End Message ---
--- Begin Message ---
Version: 8.6

The updates referred to in each of these bugs were included in today's
stable point release.

Regards,

Adam

--- End Message ---

Reply via email to