Your message dated Sat, 17 Sep 2016 13:54:49 +0000
with message-id <e1blg4v-0000wg...@franck.debian.org>
and subject line Bug#837142: fixed in libmodule-depends-perl 0.16-3
has caused the Debian Bug report #837142,
regarding libmodule-depends-perl: autopkgtest failure: t/depends.t
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
837142: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837142
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libmodule-depends-perl
Version: 0.16-2
User: debian-p...@lists.debian.org
Usertags: autopkgtest

This package is failing its autopkgtest checks on current sid.

While I haven't found the underlying issue yet, this may be caused by
perl 5.22.2-4, which removed cwd from @INC. Note that we currently (as
of pkg-perl-tools 0.33) add the absolute test directory path to @INC in
autopkgtest runs rather than set PERL_UNSAFE_INC=1 like debhelper does
for the build. See
 
https://anonscm.debian.org/git/pkg-perl/packages/pkg-perl-tools.git/commit/?id=fe96c9e0f8007b6bbd7f8ee49646588391c0cd4f
for the rationale.

  not ok 19 - Template::Extract Module::Install requires
  
  #   Failed test 'Template::Extract Module::Install requires'
  #   at t/depends.t line 109.
  #     Structures begin differing at:
  #          $got->{perl} = Does not exist
  #     $expected->{perl} = '5.006'
  ok 20 - odd outcome use of FindBin
  ok 21 - Makefile.PL exiting false should not be considered an error
  # Looks like you failed 1 test of 21.
  Dubious, test returned 1 (wstat 256, 0x100)
  Failed 1/21 subtests 
  
  Test Summary Report
  -------------------
  t/depends.t (Wstat: 256 Tests: 21 Failed: 1)
    Failed test:  19
    Non-zero exit status: 1
  
-- 
Niko Tyni   nt...@debian.org

--- End Message ---
--- Begin Message ---
Source: libmodule-depends-perl
Source-Version: 0.16-3

We believe that the bug you reported is fixed in the latest version of
libmodule-depends-perl, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 837...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Niko Tyni <nt...@debian.org> (supplier of updated libmodule-depends-perl 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sat, 17 Sep 2016 16:40:18 +0300
Source: libmodule-depends-perl
Binary: libmodule-depends-perl
Architecture: source
Version: 0.16-3
Distribution: unstable
Urgency: medium
Maintainer: Debian Perl Group <pkg-perl-maintain...@lists.alioth.debian.org>
Changed-By: Niko Tyni <nt...@debian.org>
Description:
 libmodule-depends-perl - Perl module to identify the dependencies of a 
distribution
Closes: 826484 837142
Changes:
 libmodule-depends-perl (0.16-3) unstable; urgency=medium
 .
   * Team upload.
 .
   [ Salvatore Bonaccorso ]
   * debian/control: Use HTTPS transport protocol for Vcs-Git URI
 .
   [ gregor herrmann ]
   * Change bugtracker URL(s) to HTTPS.
   * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
   * Remove Ryan Niebur from Uploaders. Thanks for your work!
 .
   [ Niko Tyni ]
   * Patch the test suite to escape braces in a regexp, fixing deprecation
     warnings. (Closes: #826484)
   * Patch the test suite to work without cwd in @INC. (Closes: #837142)
Checksums-Sha1:
 2cdc27466026af5be6375bcb6ab79fe24e9e2b46 2242 libmodule-depends-perl_0.16-3.dsc
 6398f9f39d103e75bb8c5afaf25d19a414c689b4 6116 
libmodule-depends-perl_0.16-3.debian.tar.xz
Checksums-Sha256:
 48c0dde03d817fc9eddb7fac0fc0c8e9c3e7395d482c6b32b74a93377fec0e56 2242 
libmodule-depends-perl_0.16-3.dsc
 d46628c4b8d9558918a467c22be92019748d570b82c912e88e7e8781c29e2c20 6116 
libmodule-depends-perl_0.16-3.debian.tar.xz
Files:
 1af3e8033fbad1d6595ffa35cf11ee87 2242 perl optional 
libmodule-depends-perl_0.16-3.dsc
 0b0cf74bd5a1a7bb17fa55366309c4f0 6116 perl optional 
libmodule-depends-perl_0.16-3.debian.tar.xz

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCAAGBQJX3UhSAAoJEC7A/7O3MBsfd6QQAJFFTMwCKnzyJg1cOPAM1AnB
9TmEKCWnyisrPR98SMl6PqUalBObUQBh3s9xffesqFk8cPR8zzxvoiEzqAwYTBil
axCnXvIe3T1ZI8JIdACf5jADWHWSqcJMJDlOwTThVAVqPgJq3UGP21tuJygeLpVN
GmsQt8h8gox6T5cPLPK6RfaS0XDqDizWDAJvnebJgFuDawGcoVHsnFoTiAAAtMkG
PkIjJiUnqYYEHXC2MfvugeQLqE0GE8c8Y/us9vaf6ggq72l9s+ZJrt/xT3SotOmg
dh/lVBSIol57clgnvkypZMkGaD0RpnTcAwYLh4Xd1lLqsB3g0aWPrcZrYnGIBm3r
JSwmM1qCS0D+Zy+6usPUTb3O2IwOajMlo404eF951Yv789gXJ8FmXvM91vgLn+FC
gyShGK1ovlx2IQz0I/HbVo9SvK3wlaUoWxdMB8MC0sTsWPUaya4Q+QnutWr9Rb9r
Hy3/b5aRHB8rXwSeKU1HNFCURTiLeGoVHUUxQmj1GYGzaGYWG04zFQ2nO4rxs7bp
He4B8GswpoHezB37YKCU+V/KX3AS9m10WmEvC/z+d7vnEZ6T40o8G5qWy8VMqAOJ
nlr8hV4IwLNJTnSym6kHm2l+2zvMjwbpkSQ1rwiiJirtN6dR1gLfzPWUUGGV6zAG
p2w9vIL/GA6VEOT4Cn2J
=NMpg
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to