Your message dated Tue, 20 Sep 2016 09:54:11 +0000
with message-id <>
and subject line Bug#838315: Removed package(s) from unstable
has caused the Debian Bug report #611248,
regarding [armel] unexpected symbols added for shared library
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: gnat-4.4
Version: 4.4.5-3
Severity: normal

On the way to have polyorb on armel architecture I have some problems already 
related in [1].
I have tracked the problem down to the generation of
The shared lib generation include a -lgnarl-4.4 in the command line.
If I remove it the symbol problem is solved for this library.
If I run exactly the same command on amd64 architecture with the -lgnarl-4.4 
option I get a without the symbols.
May be it's a problem in ld, but at this level I don't know how to distinguish 
between gnat and ld.


-- System Information:
Debian Release: 6.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: armel (armv5tel)

Kernel: Linux 2.6.32-5-kirkwood
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnat-4.4 depends on:
ii  gcc-4.4                   4.4.5-8        The GNU C compiler
ii  gnat-4.4-base             4.4.5-3        The GNU Compiler Collection (gnat 
ii  libc6                     2.11.2-9       Embedded GNU C Library: Shared lib
ii  libc6-dev                 2.11.2-9       Embedded GNU C Library: Developmen
ii  libgcc1                   1:4.4.5-8      GCC support library
ii  libgmp3c2                 2:4.3.2+dfsg-1 Multiprecision arithmetic library
ii  libgnat-4.4               4.4.5-3        Runtime library for GNU Ada applic
ii  libgnatprj4.4             4.4.5-3        GNU Ada Project Manager
ii  libgnatvsn4.4             4.4.5-3        GNU Ada compiler version library
ii  libmpfr4                  3.0.0-2        multiple precision floating-point 

gnat-4.4 recommends no packages.

Versions of packages gnat-4.4 suggests:
pn  ada-reference-manual          <none>     (no description available)
pn  gnat-4.4-doc                  <none>     (no description available)
pn  gnat-gps                      <none>     (no description available)
pn  gprbuild                      <none>     (no description available)

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 4.9.4-3+rm

Dear submitter,

as the package gnat-4.9 has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see

The version of this package that was in Debian prior to this removal
can still be found using

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing

Debian distribution maintenance software
Chris Lamb (the ftpmaster behind the curtain)

--- End Message ---

Reply via email to