Your message dated Tue, 20 Sep 2016 22:15:11 +0000
with message-id <>
and subject line Bug#838316: Removed package(s) from unstable
has caused the Debian Bug report #768265,
regarding gcc-4.9: Please support i386 compilation on amd64 through multiarch
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: gcc-4.9
Version: 4.9.1-19
Severity: wishlist

Dear Maintainer,

I tried to compile a simple "Hello world" C program to a 32bit binary on
my amd64 system, using:

$ gcc -m32 test.c -o test

But this does not work:

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.9/libgcc.a 
when searching for -lgcc
/usr/bin/ld: cannot find -lgcc
/usr/bin/ld: skipping incompatible 
/usr/lib/gcc/x86_64-linux-gnu/4.9/ when searching for -lgcc_s
/usr/bin/ld: cannot find -lgcc_s
collect2: error: ld returned 1 exit status

I do have libgcc-4.9-dev:i386 installed, so both libgcc.a and are 
available as 32bit binaries.
It just doesn't find them. I tried guiding it with "-L", but that did not help.

Of course I could install gcc-multilib, but that will pull in 
libc6-dev-i386:amd64, duplicating what
I already have from libc6-dev:i386. That seems like a useless waste.

Kind regards

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (990, 'testing'), (100, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.17.0+ (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gcc-4.9 depends on:
ii  binutils
ii  cpp-4.9         4.9.1-19
ii  gcc-4.9-base    4.9.1-19
ii  libc6           2.19-12
ii  libcloog-isl4   0.18.2-1
ii  libgcc-4.9-dev  4.9.1-19
ii  libgmp10        2:6.0.0+dfsg-6
ii  libisl10        0.12.2-2
ii  libmpc3         1.0.2-1
ii  libmpfr4        3.1.2-1
ii  zlib1g          1:1.2.8.dfsg-2

Versions of packages gcc-4.9 recommends:
ii  libc6-dev  2.19-12

Versions of packages gcc-4.9 suggests:
ii  gcc-4.9-doc       4.9.1-3
pn  gcc-4.9-locales   <none>
pn  gcc-4.9-multilib  <none>
pn  libasan1-dbg      <none>
pn  libatomic1-dbg    <none>
pn  libcilkrts5-dbg   <none>
pn  libgcc1-dbg       <none>
pn  libgomp1-dbg      <none>
pn  libitm1-dbg       <none>
pn  liblsan0-dbg      <none>
pn  libquadmath0-dbg  <none>
pn  libtsan0-dbg      <none>
pn  libubsan0-dbg     <none>

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 4.9.4-2+rm

Dear submitter,

as the package gcc-4.9 has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see

The version of this package that was in Debian prior to this removal
can still be found using

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing

Debian distribution maintenance software
Chris Lamb (the ftpmaster behind the curtain)

--- End Message ---

Reply via email to