Your message dated Thu, 22 Sep 2016 10:51:51 -0400
with message-id <20160922145151.2v3tl3ej62v3jyk6@gambit>
and subject line Re: Bug#837593: gnome-shell-extension-redshift: Not compatible 
with gnome-shell 3.21.x/3.22
has caused the Debian Bug report #837593,
regarding gnome-shell-extension-redshift: Not compatible with gnome-shell 
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Source: gnome-shell-extension-redshift
Version: 3.20.1-1
Severity: serious
Usertags: gnome-shell-3-22


your package gnome-shell-extension-redshift declares a strictly
versioned dependency on gnome-shell. We've uploaded gnome-shell
3.21.91 to unstable, which makes gnome-shell-extension-redshift

Please test if your package is compatible with that version and
update the information in metadata.json and the package dependencies

There will be one more development release, 3.21.92, before the final
version 3.22.0 is released [1]. gnome-shell development is frozen, so
if gnome-shell-extension-redshift works with 3.21.91, it's pretty
safe to assume it will also work with 3.21.92 and 3.22. So you might
list those as supported versions as well

Regards, Michael


--- End Message ---
--- Begin Message ---
Version: 3.20.1-2

Forgot to close in changelog.

* Michael Biebl ( wrote:
> There are some recent updates:
> In the past, it was necessary to explicitly declare supported
> gnome-shell versions in metadata.json. This was lifted in gnome-shell
> 3.21.92 [1].
> "Nowadays, the user interface has mostly stabilized with most changes
> happening under the hood. As a result, extensions written for
> previous versions of GNOME Shell are very much expected to keep
> working on updates, if it wasn't for the version check that requires
> a version bump in the extension metadata. There has been a setting to
> disable that check for a while, but it's existence isn't widely known
> (hence the common perception that "everything breaks on updates").
> While there is still some risk that an out-of-date extension can be
> enabled without error, but fails spectacularly later (where we cannot
> catch the exception), it is reasonably small by now when compared to
> the ~95% of extensions that can be "unbroken", so swap the default
> value to disable version checks by default."
> As a result, you could drop the gnome-shell << XXX version limitation
> altogether. The Debian release cycle is pretty long though, so we
> don't know yet if the gnome-shell version in Buster will actually be
> compatible with your extension today. We will release Stretch with
> GNOME Shell 3.22, so my recommendation would be to use gnome-shell
> (<< 3.23) as upper limt.
> Modifications for metadata.json are no longer required.
> Regards, Michael
> [1]

Eric Dorland <>
43CF 1228 F726 FD5B 474C  E962 C256 FBD5 0022 1E93

Attachment: signature.asc
Description: PGP signature

--- End Message ---

Reply via email to