Your message dated Wed, 12 Oct 2016 14:31:08 +0200
with message-id <20161012123108.mlulyxw2trdh7...@baumbart.home.lxtec.de>
and subject line Re: Bug#839813: mutt depends on libxapian22v5 which is for 
autoremove on testing today
has caused the Debian Bug report #839813,
regarding mutt depends on libxapian22v5 which is for autoremove on testing today
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
839813: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=839813
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: mutt
Version: 1.7.0-6
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

I ugraded my testing today, apt hinted to remove libxapian22v5, I
did so..

   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?

later I startetd mutt but this did not start with message:

/usr/bin/mutt: error while loading shared libraries: libxapian.so.22: cannot 
open shared object file: No such file or directory

   * What outcome did you expect instead?

mutt should work.

I suppose mutt should be recompiled or have a depends package
header.

Thanks for your attention.



-- Package-specific info:
NeoMutt 20160916 (1.7.0)
Copyright (C) 1996-2016 Michael R. Elkins and others.
Mutt comes with ABSOLUTELY NO WARRANTY; for details type `mutt -vv'.
Mutt is free software, and you are welcome to redistribute it
under certain conditions; type `mutt -vv' for details.

System: Linux 4.6.0-1-amd64 (x86_64)
libidn: 1.33 (compiled with 1.33)
hcache backend: tokyocabinet 1.4.48

Compiler:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/6/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 6.2.0-4' 
--with-bugurl=file:///usr/share/doc/gcc-6/README.Bugs 
--enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr 
--program-suffix=-6 --program-prefix=x86_64-linux-gnu- --enable-shared 
--enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext 
--enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ 
--enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes 
--with-default-libstdcxx-abi=new --enable-gnu-unique-object 
--disable-vtable-verify --enable-libmpx --enable-plugin --with-system-zlib 
--disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo 
--with-java-home=/usr/lib/jvm/java-1.5.0-gcj-6-amd64/jre --enable-java-home 
--with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-6-amd64 
--with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-6-amd64 
--with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar 
--enable-objc-gc --enable-multiarch --with-arch-32=i686 --with-abi=m64 
--with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic 
--enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu 
--target=x86_64-linux-gnu
Thread model: posix
gcc version 6.2.0 20160914 (Debian 6.2.0-4) 

Configure options: '--build=x86_64-linux-gnu' '--prefix=/usr' 
'--includedir=\${prefix}/include' '--mandir=\${prefix}/share/man' 
'--infodir=\${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' 
'--disable-silent-rules' '--libdir=\${prefix}/lib/x86_64-linux-gnu' 
'--libexecdir=\${prefix}/lib/x86_64-linux-gnu' '--disable-maintainer-mode' 
'--disable-dependency-tracking' '--with-mailpath=/var/mail' 
'--enable-compressed' '--enable-debug' '--enable-fcntl' '--enable-hcache' 
'--enable-gpgme' '--enable-imap' '--enable-smtp' '--enable-pop' 
'--enable-sidebar' '--enable-nntp' '--enable-notmuch' '--disable-fmemopen' 
'--with-curses' '--with-gnutls' '--with-gss' '--with-idn' '--with-mixmaster' 
'--with-sasl' '--without-gdbm' '--without-bdb' '--without-qdbm' 
'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 
-fdebug-prefix-map=/build/mutt-WCcuvM/mutt-1.7.0=. -fPIE 
-fstack-protector-strong -Wformat -Werror=format-security' 'LDFLAGS=-fPIE -pie 
-Wl,-z,relro -Wl,-z,now' 'CPPFLAGS=-Wdate-time -D_FORTIFY_SOURCE=2'

Compilation CFLAGS: -Wall -pedantic -Wno-long-long -g -O2 
-fdebug-prefix-map=/build/mutt-WCcuvM/mutt-1.7.0=. -fPIE 
-fstack-protector-strong -Wformat -Werror=format-security

Compile options:
+CRYPT_BACKEND_CLASSIC_PGP +CRYPT_BACKEND_CLASSIC_SMIME +CRYPT_BACKEND_GPGME 
+DEBUG +DL_STANDALONE +ENABLE_NLS -EXACT_ADDRESS -HOMESPOOL -LOCALES_HACK 
-SUN_ATTACHMENT +HAVE_BKGDSET +HAVE_COLOR +HAVE_CURS_SET +HAVE_GETADDRINFO 
+HAVE_GETSID +HAVE_ICONV +HAVE_LANGINFO_CODESET +HAVE_LANGINFO_YESEXPR 
+HAVE_LIBIDN +HAVE_META +HAVE_REGCOMP +HAVE_RESIZETERM +HAVE_START_COLOR 
+HAVE_TYPEAHEAD +HAVE_WC_FUNCS +ICONV_NONTRANS +USE_COMPRESSED +USE_DOTLOCK 
+USE_FCNTL -USE_FLOCK -USE_FMEMOPEN -USE_GNU_REGEX +USE_GSS +USE_HCACHE 
+USE_IMAP +USE_NOTMUCH +USE_NNTP +USE_POP +USE_SASL +USE_SETGID +USE_SIDEBAR 
+USE_SMTP +USE_SSL_GNUTLS -USE_SSL_OPENSSL 
-DOMAIN
MIXMASTER="mixmaster"
-ISPELL
SENDMAIL="/usr/sbin/sendmail"
MAILPATH="/var/mail"
PKGDATADIR="/usr/share/mutt"
SYSCONFDIR="/etc"
EXECSHELL="/bin/sh"

patch-attach-headers-color-neomutt
patch-compress-neomutt
patch-cond-date-neomutt
patch-encrypt-to-self-neomutt
patch-fmemopen-neomutt
patch-forgotten-attachments-neomutt
patch-ifdef-neomutt
patch-index-color-neomutt
patch-initials-neomutt
patch-keywords-neomutt
patch-limit-current-thread-neomutt
patch-lmdb-neomutt
patch-multiple-fcc-neomutt
patch-nested-if-neomutt
patch-new-mail-neomutt
patch-nntp-neomutt
patch-notmuch-neomutt
patch-progress-neomutt
patch-quasi-delete-neomutt
patch-reply-with-xorig-neomutt
patch-sensible-browser-neomutt
patch-sidebar-neomutt
patch-skip-quoted-neomutt
patch-smime-encrypt-self-neomutt
patch-status-color-neomutt
patch-timeout-neomutt
patch-tls-sni-neomutt

To learn more about NeoMutt, visit: http://www.neomutt.org/
If you find a bug in NeoMutt, please raise an issue at:
    https://github.com/neomutt/neomutt/issues
or send an email at: <neomutt-de...@neomutt.org>


-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.6.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages mutt depends on:
ii  libassuan0        2.4.3-1
ii  libc6             2.24-3
ii  libcomerr2        1.43.3-1
ii  libgnutls30       3.5.4-2
ii  libgpg-error0     1.24-1
ii  libgpgme11        1.7.0-1
ii  libgssapi-krb5-2  1.14.3+dfsg-2
ii  libidn11          1.33-1
ii  libk5crypto3      1.14.3+dfsg-2
ii  libkrb5-3         1.14.3+dfsg-2
ii  libncursesw5      6.0+20160917-1
ii  libnotmuch4       0.22.2-1+b1
ii  libsasl2-2        2.1.26.dfsg1-15
ii  libtinfo5         6.0+20160917-1
ii  libtokyocabinet9  1.4.48-10

Versions of packages mutt recommends:
ii  libsasl2-modules  2.1.26.dfsg1-15
ii  locales           2.24-3
ii  mime-support      3.60

Versions of packages mutt suggests:
ii  aspell                                     0.60.7~20110707-3+b1
ii  ca-certificates                            20160104
ii  exim4-daemon-heavy [mail-transport-agent]  4.87-3+b1
ii  gnupg                                      2.1.15-3
ii  ispell                                     3.4.00-5
pn  mixmaster                                  <none>
ii  openssl                                    1.0.2j-1
pn  urlview                                    <none>

Versions of packages mutt is related to:
ii  mutt  1.7.0-6

-- no debconf information

--- End Message ---
--- Begin Message ---
* Gregor Zattler <telegr...@gmx.net> [2016-10-11 23:07 +0200]:

> Hi Elimar,
> * Elimar Riesebieter <riese...@lxtec.de> [07. Okt. 2016]:
> > * Gregor Zattler <telegr...@gmx.net> [2016-10-07 00:18 +0200]:
> >> * Elimar Riesebieter <riese...@lxtec.de> [06. Okt. 2016]:
> > [...]
> >>> What tells
> >>> $ ldd $(which mutt) | grep xapian?
> >> 
> >> libxapian.so.22 => /usr/lib/x86_64-linux-gnu/libxapian.so.22 
> >> (0x00007f7f4d900000)
> > 
> > On my systems mutt 1.7.0-6 should have been build against
> > libxapian-dev 1.4 which let mutt point to:
> > 
> > libxapian.so.30 => /usr/lib/i386-linux-gnu/sse2/libxapian.so.30 (0xb680e000)
> > libxapian.so.30 => /usr/lib/x86_64-linux-gnu/libxapian.so.30 
> > (0x00007f9790569000)
> > 
> > From where did you get the mutt package? Did you compiled it by
> > your self?
> 
> This is mutt-1.70-6 from testing repository but I compiled
> notmuch myself and this was the reason fro the wrong library
> version (don't ask me why.  Since I updated notmuch
> 
> $ ldd $(which mutt) | grep xapian
>         libxapian.so.30 =>
>         /usr/lib/x86_64-linux-gnu/libxapian.so.30
>         (0x00007fad41a27000)

So bug closed hereby.

Thanks
Elimar
-- 
  You cannot propel yourself forward by
  patting yourself on the back.

Attachment: signature.asc
Description: PGP signature


--- End Message ---

Reply via email to