Your message dated Thu, 13 Oct 2016 01:04:20 +0000
with message-id <e1buury-0004cj...@franck.debian.org>
and subject line Bug#812851: fixed in yaml-cpp 0.5.2-4
has caused the Debian Bug report #812851,
regarding libyaml-cpp-dev: libboost-dev dependency missing
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
812851: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=812851
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libyaml-cpp-dev
Version: 0.5.2-3
Severity: normal

As the subject says, boost headers are needed to build programs
against libyaml-cpp-dev, so they should be added to the list of
dependencies:

/usr/include/yaml-cpp/node/ptr.h:11:32: fatal error:
boost/shared_ptr.hpp: No such file or directory

Thanks!

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: unable to detect

Versions of packages libyaml-cpp-dev depends on:
ii  libyaml-cpp0.5v5  0.5.2-3

libyaml-cpp-dev recommends no packages.

libyaml-cpp-dev suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: yaml-cpp
Source-Version: 0.5.2-4

We believe that the bug you reported is fixed in the latest version of
yaml-cpp, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 812...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Novotny <p...@paulnovo.us> (supplier of updated yaml-cpp package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Wed, 12 Oct 2016 19:48:11 -0400
Source: yaml-cpp
Binary: libyaml-cpp0.5v5 libyaml-cpp-dev
Architecture: source amd64
Version: 0.5.2-4
Distribution: unstable
Urgency: medium
Maintainer: Lifeng Sun <lifong...@gmail.com>
Changed-By: Paul Novotny <p...@paulnovo.us>
Description:
 libyaml-cpp-dev - YAML parser and emitter for C++ - development files
 libyaml-cpp0.5v5 - YAML parser and emitter for C++
Closes: 808714 812851 814499
Changes:
 yaml-cpp (0.5.2-4) unstable; urgency=medium
 .
   * Make the build reproducible (Closes: #808714)
   * Add libboost-dev dependency (Closes: #812851)
   * Fix yaml-cpp 0.5.2 issue (Closes: #814499)
   * Fix lintian warnings: spelling, standards-version, and Vcs-Git
Checksums-Sha1:
 b71bd01c04928e5bd3eb1a3a77391fd78e8da010 1992 yaml-cpp_0.5.2-4.dsc
 49519442fce887cd4275c1ae955df15ce7c79f3a 5920 yaml-cpp_0.5.2-4.debian.tar.xz
 b91352fa5493f9946ea521a08d0e43455ee8ab2f 189076 
libyaml-cpp-dev_0.5.2-4_amd64.deb
 21ce201a4b34297b1bca51df087b7d17fe05be4d 1909440 
libyaml-cpp0.5v5-dbgsym_0.5.2-4_amd64.deb
 a8888b61a95e9d2566558ce9fd2335dc872759ea 151422 
libyaml-cpp0.5v5_0.5.2-4_amd64.deb
Checksums-Sha256:
 d763be2307610016e19bb3094f3aa2ad6736ffc90f5929b9b357ee59d5c04cbc 1992 
yaml-cpp_0.5.2-4.dsc
 c1e10ca08fb161d89fe950499138753b02223a5d2a213d165fc0c8f7adfc4299 5920 
yaml-cpp_0.5.2-4.debian.tar.xz
 04a6b08d237036c890c2dd9a00b27e47fc44474f6937d9971b642187bc65e959 189076 
libyaml-cpp-dev_0.5.2-4_amd64.deb
 75848aaa757f339630269aea2ecfd2f5f1a00f9f6191701b0613b1421d7e7029 1909440 
libyaml-cpp0.5v5-dbgsym_0.5.2-4_amd64.deb
 c8da182c6b8b93c7ecb84386e70bb7b60fc73d82d9243430fc668c584e6f3e5b 151422 
libyaml-cpp0.5v5_0.5.2-4_amd64.deb
Files:
 187cbb92d22683253d2fb6573c764204 1992 devel optional yaml-cpp_0.5.2-4.dsc
 0954605e35acba87b3d1a2c25ca6903c 5920 devel optional 
yaml-cpp_0.5.2-4.debian.tar.xz
 e895b4fbcaced551d7ab98868b5fce07 189076 libdevel optional 
libyaml-cpp-dev_0.5.2-4_amd64.deb
 c606cf8090ec234f28d1f1b7559a2f4b 1909440 debug extra 
libyaml-cpp0.5v5-dbgsym_0.5.2-4_amd64.deb
 12799c2a34fcb4bd39b3018a2b4f2876 151422 libs optional 
libyaml-cpp0.5v5_0.5.2-4_amd64.deb

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJX/tcoAAoJEP6qEy+YMZHq5wIP/2sxGLyVsPDtQR+EI6zvw0ap
kiHZ6KIXrk5fZqMhdlnUAh4kT74NG8yWiX/MscKDXrMd/Xcqi+0Fi/W9st+cvPrV
2Fz8YY2LOFcM+eXK9k7CkWRbL4JsZEUHmtwOZxwDMqZtD/K3KgJDFPipveL9bwij
QtrPtdBTSmjKanvXZxo4d6yXJXfDptSQgeN7q/KVrYKgZUq/jxMZ+pQZOhh++FU3
LY+Hv+rR+UM8KzHD6fBey7hojQj2Uy77DlSE83RlVpTzcEa98jG7YP03HN6n52Dh
CdOcp5alh+vxQXzbZhy00GxIREK2GJbAqPrRWxWJGXo+/G+jNpPBbHIeE1X2PBGh
/5uol/lsqrs58eGBeIIxNJVRrjlciGNq/RAidqPNjrM7PTgbKcHf9u9rGRTWOVq5
fierkz/0b2PjpwzZ0BE+fzJxdQXiozMeu0hFtvw9ool+YVArXbtL7HKMUNDXNmvk
hBlRMWwnnCmPnBD1j+4V2y2kp2mUK5FbOpUiCbyg0xU5+xEW0My5pIgRqbw4d/Mc
hBX2oJnEUiWnVYrL1fodcWJ8kz8wh0/HSXtJOeUUNfHmesDy1SV6YhOT2Zk4sETR
fhk4E8u7DtCNWsHIS4973jKIRxdHVO18GgCCIfQE6mnTJEyEWpL5gj2RZOKkExK7
6emus8PrU60K1cxP5yOd
=mt5o
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to