Your message dated Sat, 15 Oct 2016 02:43:11 -0500
with message-id <>
and subject line Re: Bug#670097: Possibly fixed upstream
has caused the Debian Bug report #670097,
regarding gnome-shell crashes often with JS errors
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: gnome-shell
Severity: important


It crashes almost every day. I noticed it when I could not unlock my
system after leaving it under lock state for some time. I have to get
into text console (ctrl alt f2) and then kill gnome-screensaver, come
back to graphical console and restart gnome shell (gnome-shell
--replace) with an open window of gnome terminal (using alt tab). In
this state Activities or other menus on the top panel does not

The error I see on the terminal after it crashes is

      JS LOG: pushModal: invocation of begin_modal failed
      JS LOG: pushModal: invocation of begin_modal failed

and there are some error messages when gnome-shell starts

gnome-shell --replace&
[3] 7560
pravi@savannah:/tmp$       JS LOG: GNOME Shell started at Tue Jun 12
2012 15:59:10 GMT+0530 (IST)
    JS ERROR: !!!   Exception was: Error: Unable to construct boxed
type KeyFile since it has no zero-args <constructor>, can only wrap an
existing one
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = '"gjs_throw"'
    JS ERROR: !!!     stack = '"("Unable to construct boxed type
KeyFile since it has no zero-args <constructor>, can only wrap an
existing one")@gjs_throw:0
([object Array])@/usr/share/gnome-shell/js/ui/remoteSearch.js:50
    JS ERROR: !!!     message = '"Unable to construct boxed type
KeyFile since it has no zero-args <constructor>, can only wrap an
existing one"'

(gnome-shell:7560): folks-WARNING **: Failed to find primary
PersonaStore with type ID 'eds' and ID 'system'.
Individuals will not be linked properly and creating new links between
Personas will not work.
The configured primary PersonaStore's backend may not be installed. If
you are unsure, check with your distribution.

I have noticed it from 3.2 itself. I use a work around, but it would
be difficult for users not familiar with command line.

Other windows I commonly have opened are emacs, gnotem icedove and iceweasel.

പ്രവീണ്‍ അരിമ്പ്രത്തൊടിയില്‍
You have to keep reminding your government that you don't get your
rights from them; you give them permission to rule, only so long as
they follow the rules: laws and constitution.

--- End Message ---
--- Begin Message ---
On Thu, Aug 27, 2015 at 09:18:01PM +0200, intrigeri wrote:
> this is about
> Bob Ham wrote (04 Jun 2013 09:21:42 GMT) :
> > I see the same bug as reported by John Winters.  Apparently there's a 
> > deadlock in the
> > garbage collector of the Javascript engine, that is consistent with the 
> > observed
> > behaviour and for which there are patches:
> >
> These patches should be included in Debian Jessie. Can anyone
> reproduce this bug there? If so, please let us know, and perhaps file
> new bug reports about it: it seems to me that the current one mixes
> unrelated issues, some that were fixed by GNOME Shell 3.4, some that
> were not.

closing as there has been no response

--- End Message ---

Reply via email to