Your message dated Mon, 17 Oct 2016 11:24:30 +0000
with message-id <>
and subject line Bug#840374: fixed in binutils 2.27-9
has caused the Debian Bug report #840374,
regarding binutils-arm-linux-gnueabi: ld.bfd segfaults when attempting to 
include binary blob
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: binutils-arm-linux-gnueabi
Version: 2.27-8
Severity: normal

Dear Maintainer,
My build system uses LD with a linker script to include a binary blob
in an elf file.  arm-linux-gnueabi-ld.bfd segfaults, but works correctly.

To reproduce:
  dd if=/dev/zero of=blob bs=1k count=1

  cat  > linkscript.ld <<EOF
  SECTIONS { ._archive_cpio : ALIGN(4)
           { _cpio_archive = . ;
             *(.*) ;
             _cpio_archive_end = . ; }

  arm-linux-gnueabi-ld.bfd  -T linkscript.ld -m armelf_linux_eabi \
                            --format binary --oformat elf32-littlearm  \
                            -r blob -o foo.o

Peter C

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386, armhf, armel, arm64

Kernel: Linux 4.8.0+ (SMP w/8 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: systemd (via /run/systemd/system)

Versions of packages binutils-arm-linux-gnueabi depends on:
ii  binutils  2.27-8
ii  libc6     2.24-3
ii  zlib1g    1:1.2.8.dfsg-2+b1

binutils-arm-linux-gnueabi recommends no packages.

Versions of packages binutils-arm-linux-gnueabi suggests:
pn  binutils-doc  <none>

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: binutils
Source-Version: 2.27-9

We believe that the bug you reported is fixed in the latest version of
binutils, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matthias Klose <> (supplier of updated binutils package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing

Hash: SHA256

Format: 1.8
Date: Mon, 17 Oct 2016 13:12:51 +0200
Source: binutils
Binary: binutils binutils-dev binutils-multiarch binutils-multiarch-dev 
binutils-hppa64-linux-gnu binutils-doc binutils-source binutils-s390x-linux-gnu 
binutils-powerpc64le-linux-gnu binutils-powerpc-linux-gnu 
binutils-aarch64-linux-gnu binutils-arm-linux-gnueabihf 
binutils-arm-linux-gnueabi binutils-mips-linux-gnu binutils-mipsel-linux-gnu 
binutils-alpha-linux-gnu binutils-hppa-linux-gnu binutils-m68k-linux-gnu 
binutils-mips64-linux-gnuabi64 binutils-mips64el-linux-gnuabi64 
binutils-powerpc-linux-gnuspe binutils-powerpc64-linux-gnu 
binutils-sh4-linux-gnu binutils-sparc64-linux-gnu 
binutils-mips64-linux-gnuabin32 binutils-mips64el-linux-gnuabin32 
binutils-mipsisa32r6-linux-gnu binutils-mipsisa32r6el-linux-gnu 
binutils-mipsisa64r6-linux-gnuabin32 binutils-mipsisa64r6el-linux-gnuabin32 
binutils-mipsisa64r6-linux-gnuabi64 binutils-mipsisa64r6el-linux-gnuabi64
Architecture: source
Version: 2.27-9
Distribution: unstable
Urgency: medium
Maintainer: Matthias Klose <>
Changed-By: Matthias Klose <>
 binutils   - GNU assembler, linker and binary utilities
 binutils-aarch64-linux-gnu - GNU binary utilities, for aarch64-linux-gnu target
 binutils-alpha-linux-gnu - GNU binary utilities, for alpha-linux-gnu target
 binutils-arm-linux-gnueabi - GNU binary utilities, for arm-linux-gnueabi target
 binutils-arm-linux-gnueabihf - GNU binary utilities, for arm-linux-gnueabihf 
 binutils-dev - GNU binary utilities (BFD development files)
 binutils-doc - Documentation for the GNU assembler, linker and binary utilities
 binutils-hppa-linux-gnu - GNU binary utilities, for hppa-linux-gnu target
 binutils-hppa64-linux-gnu - GNU assembler, linker and binary utilities 
targeted for hppa64-li
 binutils-m68k-linux-gnu - GNU binary utilities, for m68k-linux-gnu target
 binutils-mips-linux-gnu - GNU binary utilities, for mips-linux-gnu target
 binutils-mips64-linux-gnuabi64 - GNU binary utilities, for 
mips64-linux-gnuabi64 target
 binutils-mips64-linux-gnuabin32 - GNU binary utilities, for 
mips64-linux-gnuabin32 target
 binutils-mips64el-linux-gnuabi64 - GNU binary utilities, for 
mips64el-linux-gnuabi64 target
 binutils-mips64el-linux-gnuabin32 - GNU binary utilities, for 
mips64el-linux-gnuabin32 target
 binutils-mipsel-linux-gnu - GNU binary utilities, for mipsel-linux-gnu target
 binutils-mipsisa32r6-linux-gnu - GNU binary utilities, for 
mipsisa32r6-linux-gnu target
 binutils-mipsisa32r6el-linux-gnu - GNU binary utilities, for 
mipsisa32r6el-linux-gnu target
 binutils-mipsisa64r6-linux-gnuabi64 - GNU binary utilities, for 
mipsisa64r6-linux-gnuabi64 target
 binutils-mipsisa64r6-linux-gnuabin32 - GNU binary utilities, for 
mipsisa64r6-linux-gnuabin32 target
 binutils-mipsisa64r6el-linux-gnuabi64 - GNU binary utilities, for 
mipsisa64r6el-linux-gnuabi64 target
 binutils-mipsisa64r6el-linux-gnuabin32 - GNU binary utilities, for 
mipsisa64r6el-linux-gnuabin32 target
 binutils-multiarch - Binary utilities that support multi-arch targets
 binutils-multiarch-dev - GNU binary utilities that support multi-arch targets 
(BFD develop
 binutils-powerpc-linux-gnu - GNU binary utilities, for powerpc-linux-gnu target
 binutils-powerpc-linux-gnuspe - GNU binary utilities, for powerpc-linux-gnuspe 
 binutils-powerpc64-linux-gnu - GNU binary utilities, for powerpc64-linux-gnu 
 binutils-powerpc64le-linux-gnu - GNU binary utilities, for 
powerpc64le-linux-gnu target
 binutils-s390x-linux-gnu - GNU binary utilities, for s390x-linux-gnu target
 binutils-sh4-linux-gnu - GNU binary utilities, for sh4-linux-gnu target
 binutils-source - GNU assembler, linker and binary utilities (source)
 binutils-sparc64-linux-gnu - GNU binary utilities, for sparc64-linux-gnu target
Closes: 834147 835544 839956 840374
 binutils (2.27-9) unstable; urgency=medium
   * Update, taken from the 2.27 branch 20161014.
     - Fix PR ld/20608, PR ld/20545, PR gold/20238.
   * Fix cross build for non-standard cross archs (Helmut Grohne).
     Closes: #839956.
   * Fix ld segfault on ARM32, taken from the trunk. Closes: #840374.
   * Fix PR ld/20648, taken from the trunk. Closes: #835544.
   * Fix PR ld/20649, using proposed patch. Closes: #834147.
 7764c6c05caa0f59ca30eb922dbe5db4dda8e346 4920 binutils_2.27-9.dsc
 63547242ca00144f8e80d3a94959431440e8e1bd 113348 binutils_2.27-9.diff.gz
 d46b65a92ea4a85f6379a84b0211269fd7253b2fb8f265429a50e7c33115ab03 4920 
 201a9060721d38f5e0a4658c3ffa0ef3c9d415858cbf3a2ae9cdf25d1bc1264a 113348 
 dcd5a3fd0618d9c1e1b801b0cf64e15c 4920 devel optional binutils_2.27-9.dsc
 9490b1f362220248d1d7a69f0af45185 113348 devel optional binutils_2.27-9.diff.gz



--- End Message ---

Reply via email to