Your message dated Thu, 01 Dec 2016 19:49:42 +0000
with message-id <e1ccxmu-00067c...@fasolo.debian.org>
and subject line Bug#840699: fixed in ninix-aya 5.0.2-1
has caused the Debian Bug report #840699,
regarding ninix-aya: does not work with ruby-gnome2 3.0.9-1
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
840699: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=840699
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: ninix-aya
Version: 4.999.2-1
Severity: serious
Tags: experimental

Dear Maintainer,

I plan to upload ruby-gnome2 3.0.9 into unstable.
Before I do so, I test rdep packages in experimental uploading.
ninix-aya does not work with ruby-gnome2 3.0.9-1.

-----
        :
/usr/lib/ruby/vendor_ruby/ninix/menu.rb:836:in `new': 
'Gtk::MenuItem#initialize(label, use_underline=false)' style has been 
deprecated. Use 'Gtk::MenuItem#initialize(:label => label, :use_underline => 
use_underline)' style.
/usr/lib/ruby/vendor_ruby/ninix/menu.rb:836:in `new': 
'Gtk::MenuItem#initialize(label, use_underline=false)' style has been 
deprecated. Use 'Gtk::MenuItem#initialize(:label => label, :use_underline => 
use_underline)' style.
/usr/lib/ruby/vendor_ruby/ninix/pix.rb:266:in `pixbuf_new_from_file': 
'Gdk::Pixbuf' has been deprecated. Use 'GdkPixbuf::Pixbuf'.
/usr/lib/ruby/vendor_ruby/gdk_pixbuf2/deprecated.rb:48:in `new': 
GdkPixbuf::Pixbuf.new(path) is deprecated. Use GdkPixbuf::Pixbuf.new(:file => 
path) instead.
/usr/lib/ruby/vendor_ruby/glib2/deprecatable.rb:112:in `const_missing': 
uninitialized constant GdkPixbuf::Pixbuf::InterpType
Did you mean?  GdkPixbuf::InterpType
         from /usr/lib/ruby/vendor_ruby/ninix/pix.rb:279:in `create_icon_pixbuf'
         from /usr/lib/ruby/vendor_ruby/ninix/menu.rb:661:in 
`create_ghost_menuitem'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:812:in `create_menuitem'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:472:in `call'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:472:in `handle_request'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:367:in `create_menuitem'
         from /usr/lib/ruby/vendor_ruby/ninix/metamagic.rb:103:in `baseinfo='
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:1227:in `add_sakura'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:535:in `do_install'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:1571:in 
`open_file_chooser'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:1563:in `call'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:1563:in `response'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:1441:in `block in 
initialize'
         from /usr/lib/ruby/vendor_ruby/gobject-introspection/loader.rb:114:in 
`invoke'
         from /usr/lib/ruby/vendor_ruby/gobject-introspection/loader.rb:114:in 
`block in define_singleton_method'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:950:in `run'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:132:in `main'
         from /usr/lib/ruby/vendor_ruby/ninix_main.rb:1795:in `<main>'
        :
-----

Can you fix it to work with ruby-gnome2 3.0.9-1 ?
I want to make ruby-gnome2 3.0.9-1 in time for stretch freeze (2016-Nov-05).
-- 
Regards,
        dai

GPG Fingerprint = 0B29 D88E 42E6 B765 B8D8 EA50 7839 619D D439 668E

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 
'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.7.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8) (ignored: LC_ALL 
set to ja_JP.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages ninix-aya depends on:
ii  ruby            1:2.3.0+4
ii  ruby-gettext    3.2.2-1
ii  ruby-gio2       3.0.9-1
ii  ruby-gstreamer  3.0.9-1
ii  ruby-gtk3       3.0.9-1
ii  ruby-narray     0.6.1.1-2+b3
ii  ruby-zip        1.2.0-1

ninix-aya recommends no packages.

Versions of packages ninix-aya suggests:
pn  kawari8  <none>

-- no debconf information

Attachment: signature.asc
Description: PGP signature


--- End Message ---
--- Begin Message ---
Source: ninix-aya
Source-Version: 5.0.2-1

We believe that the bug you reported is fixed in the latest version of
ninix-aya, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 840...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Ying-Chun Liu (PaulLiu) <paul...@debian.org> (supplier of updated ninix-aya 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Fri, 02 Dec 2016 03:28:35 +0800
Source: ninix-aya
Binary: ninix-aya
Architecture: source amd64
Version: 5.0.2-1
Distribution: unstable
Urgency: low
Maintainer: Ying-Chun Liu (PaulLiu) <paul...@debian.org>
Changed-By: Ying-Chun Liu (PaulLiu) <paul...@debian.org>
Description:
 ninix-aya  - Interactive fake-AI Ukagaka-compatible desktop mascot program
Closes: 840699
Changes:
 ninix-aya (5.0.2-1) unstable; urgency=low
 .
   * New upstream release
     - Now it works with ruby-gnome2 (>= 3.0.9) (Closes: #840699)
   * Bump debhelper version to 10
Checksums-Sha1:
 7239374687e1e09295fe1351399d69e685a4eab7 1796 ninix-aya_5.0.2-1.dsc
 f8dca1e895d16db2dfb775b0790ca809858a84f9 321570 ninix-aya_5.0.2.orig.tar.gz
 8504e39b37fde0dd5b97ae348e801929975be370 7320 ninix-aya_5.0.2-1.debian.tar.xz
 d342e4980c5bfbec8354d21eb7a6c25d9e2e04d7 5808 ninix-aya_5.0.2-1_amd64.buildinfo
 1a798ef649c08bb9bedcaf8f4f0cabb7b420c091 252182 ninix-aya_5.0.2-1_amd64.deb
Checksums-Sha256:
 7aec0fa5ba9992fa57e9442bb7e2a46243261b81b27fda23cb6339c5a8963b55 1796 
ninix-aya_5.0.2-1.dsc
 d03748126b3cb8c634167a2301c78d088b4d3cdc0c7ca6e96b7b9d9040566d1a 321570 
ninix-aya_5.0.2.orig.tar.gz
 85f55bb66fd252f71cd50b2f168deed9fa22d526e966de982ca94a5a401d583d 7320 
ninix-aya_5.0.2-1.debian.tar.xz
 6a5abff78f6e6edfa4f176149d1c274c383c7a3da7bedbd13ec8e743b9862645 5808 
ninix-aya_5.0.2-1_amd64.buildinfo
 9cf52dd4485c38ddc0e6ac93900adb708c5f837fc9d1e7e1ad3a1167a4e80ead 252182 
ninix-aya_5.0.2-1_amd64.deb
Files:
 1b0d7d3fbc6aac8144899a9c865c126c 1796 games extra ninix-aya_5.0.2-1.dsc
 9dfa1464cd4ee7626794ee92625c5b91 321570 games extra ninix-aya_5.0.2.orig.tar.gz
 d14f5bb41bb7bc83206981ea050c16f9 7320 games extra 
ninix-aya_5.0.2-1.debian.tar.xz
 e9bfec119f7e84b2a6dc7671b53af3c4 5808 games extra 
ninix-aya_5.0.2-1_amd64.buildinfo
 0ce91690082dc214a4e308f1673a30a6 252182 games extra ninix-aya_5.0.2-1_amd64.deb

-----BEGIN PGP SIGNATURE-----

iQJHBAEBCgAxFiEEo2h49GQQhoFgDLZIRBc/oT0FiIgFAlhAevkTHHBhdWxsaXVA
ZGViaWFuLm9yZwAKCRBEFz+hPQWIiDnCEAC1vLRLwYfhEpaxu0ST4TFlF82JhhCj
recx1z76JtwP57I4RYJlltrjZ3Yt7Tev8Tehhom6NKaQYex459xHk+8txYLDKwGt
SigfjswiC45TchH6daoaIQpctxQZkGBvBxHPKN6O9eiwMqQIMYT/Olkp3mnIUr71
UPPFNEkz1Zcb6A/7OZ5h3RgC+pG4QSo3UglDZLSUapicGH354+TlAggm/JYyhgWS
mC7vheeAcUd4CpoJbtCga55NgRDvC83lvtdRbSnhWQkGLv8oGq12D3GkcjWUN6zJ
ebfryeVuIhzIR0P+LUIta9g0V4Vxmn8MLD9ZeNtSDrove+wNAUx+p+iKx+KfkTLj
MKr0wLNrkZGC6b77mZaJodMgI25F8RRixlh3tcdM/D7att3wGeTd/IRW5TMExBNn
aVnXjyHa5V7tBN1aLpDJXM9iWrDP7Ij4LAoxvR/S49cTNWhHY4ePDo/xZtzUZqjw
82d+SVytibDDL/XkBAsJb64lSU1CNWjUCSTInt4Xd1uYRVzJNSwMv60tBZE399fv
8hOVQFoVohJtyfeHho0Zf5Ha38821RhrotMLcoz4OWpvulKP6BcVVNzJ34Wsy90w
BmvxpmKgPy/WZQBb2iySnUd3PqPpSAxk2ZYTBVl4ZG6duK2QNnSQD7PUYic3Ixqu
DJ1VXRlldGsXTA==
=p3M0
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to