Your message dated Fri, 13 Jan 2017 13:05:30 +0000
with message-id <e1cs1xu-0009dr...@fasolo.debian.org>
and subject line Bug#841781: Removed package(s) from unstable
has caused the Debian Bug report #783246,
regarding php5en(dis)mod: mandatory space between semicolon and priority key
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
783246: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783246
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: php5-common
Version: 5.5.9+dfsg-1ubuntu4.9
Severity: wishlist
Tags: patch

Dear Maintainer,

When menaging infrastructure using software such as Puppet Auegas tools would
handle *.ini files. Augeas PHP lens does not allow space(s) at the beginning 
of comments. In combination with mandatory space after semicolon as defined 
in regex in function php5-helper::get_prioroity it makes automation impossible. 
 

If priority in extension.ini is set as: ;priority=30 setting will be disregarded
and default priority will be used insetad.

Regardles of space between semicolon eg ;priority=30/; priority=30 and priority
key defined priroity should be used resulgint in creating 
/etc/sapi/conf.d/30-exension.ini

Following regex will match both ;priority=30 and ; priority=30
priority=$(sed -ne "s/^;[ ]\?priority=\([0-9]\+\)$/\\1/p" $source_ini)

Regards,
Goran Miskovic

-- Package-specific info:
==== Additional PHP 5 information ====

++++ PHP 5 SAPI (php5query -S): ++++
fpm
cli

++++ PHP 5 Extensions (php5query -M -v): ++++
solr (Enabled for fpm by local administrator)
solr (Enabled for cli by local administrator)
opcache (Enabled for fpm by maintainer script)
opcache (Enabled for cli by maintainer script)
mysql (Enabled for fpm by maintainer script)
mysql (Enabled for cli by maintainer script)
pdo (Enabled for fpm by maintainer script)
pdo (Enabled for cli by maintainer script)
xmlrpc (Enabled for fpm by maintainer script)
xmlrpc (Enabled for cli by maintainer script)
memcache (Enabled for fpm by maintainer script)
memcache (Enabled for cli by local administrator)
json (Enabled for fpm by maintainer script)
json (Enabled for cli by maintainer script)
tidy (Enabled for fpm by maintainer script)
tidy (Enabled for cli by maintainer script)
gd (Enabled for fpm by maintainer script)
gd (Enabled for cli by maintainer script)
mysqli (Enabled for fpm by maintainer script)
mysqli (Enabled for cli by maintainer script)
readline (Enabled for fpm by maintainer script)
readline (Enabled for cli by maintainer script)
imagick (Enabled for fpm by local administrator)
imagick (Enabled for cli by local administrator)
pdo_mysql (Enabled for fpm by maintainer script)
pdo_mysql (Enabled for cli by maintainer script)
curl (Enabled for fpm by maintainer script)
curl (Enabled for cli by maintainer script)

++++ Configuration files: ++++
**** /etc/php5/mods-available/pdo.ini ****
extension=pdo.so

**** /etc/php5/mods-available/opcache.ini ****
zend_extension=opcache.so


-- System Information:
Debian Release: jessie/sid
  APT prefers trusty-updates
  APT policy: (500, 'trusty-updates'), (500, 'trusty-security'), (500, 'trusty')
Architecture: amd64 (x86_64)

Kernel: Linux 3.13.0-49-generic (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages php5-common depends on:
ii  libc6      2.19-0ubuntu6.6
ii  lsof       4.86+dfsg-1ubuntu2
ii  php5-json  1.3.2-2build1
ii  psmisc     22.20-1ubuntu2
ii  sed        4.2.2-4ubuntu1
ii  ucf        3.0027+nmu1

php5-common recommends no packages.

Versions of packages php5-common suggests:
pn  php5-user-cache  <none>

Versions of packages php5-cli depends on:
ii  libbz2-1.0    1.0.6-5
ii  libc6         2.19-0ubuntu6.6
ii  libdb5.3      5.3.28-3ubuntu3
ii  libedit2      3.1-20130712-2
ii  libmagic1     1:5.14-2ubuntu3.3
ii  libpcre3      1:8.31-2ubuntu2
ii  libssl1.0.0   1.0.1f-1ubuntu2.11
ii  libxml2       2.9.1+dfsg1-3ubuntu4.4
ii  mime-support  3.54ubuntu1.1
ii  tzdata        2015c-0ubuntu0.14.04
ii  ucf           3.0027+nmu1
ii  zlib1g        1:1.2.8.dfsg-1ubuntu1

Versions of packages php5-cli recommends:
ii  php5-readline  5.5.9+dfsg-1ubuntu4.9

Versions of packages php5-cli suggests:
ii  php-pear  5.5.9+dfsg-1ubuntu4.9

Versions of packages php5-fpm depends on:
ii  dpkg                1.17.5ubuntu5.4
ii  libbz2-1.0          1.0.6-5
ii  libc6               2.19-0ubuntu6.6
ii  libdb5.3            5.3.28-3ubuntu3
ii  libmagic1           1:5.14-2ubuntu3.3
ii  libpcre3            1:8.31-2ubuntu2
ii  libssl1.0.0         1.0.1f-1ubuntu2.11
ii  libsystemd-daemon0  204-5ubuntu20.11
ii  libxml2             2.9.1+dfsg1-3ubuntu4.4
ii  mime-support        3.54ubuntu1.1
ii  sysv-rc             2.88dsf-41ubuntu6.1
ii  tzdata              2015c-0ubuntu0.14.04
ii  ucf                 3.0027+nmu1
ii  zlib1g              1:1.2.8.dfsg-1ubuntu1

Versions of packages php5-fpm suggests:
ii  php-pear  5.5.9+dfsg-1ubuntu4.9

-- no debconf information
--- php5-helper 2015-04-24 09:30:25.468928513 +0000
+++ php5-helper.mine    2015-04-24 09:31:46.716927818 +0000
@@ -132,7 +132,7 @@
     module_exists $modname || module_ret=$?

     if [ "$module_ret" -eq 0 ]; then
-       priority=$(sed -ne "s/^; priority=\([0-9]\+\)$/\\1/p" $source_ini)
+       priority=$(sed -ne "s/^;[ ]\?priority=\([0-9]\+\)$/\\1/p" $source_ini)
        [ -z "$priority" ] && priority=20
        echo $priority
        return 0

--- php5-helper 2015-04-24 09:30:25.468928513 +0000
+++ php5-helper.mine    2015-04-24 09:31:46.716927818 +0000
@@ -132,7 +132,7 @@
     module_exists $modname || module_ret=$?

     if [ "$module_ret" -eq 0 ]; then
-       priority=$(sed -ne "s/^; priority=\([0-9]\+\)$/\\1/p" $source_ini)
+       priority=$(sed -ne "s/^;[ ]\?priority=\([0-9]\+\)$/\\1/p" $source_ini)
        [ -z "$priority" ] && priority=20
        echo $priority
        return 0

--- php5-helper 2015-04-24 09:30:25.468928513 +0000
+++ php5-helper.mine    2015-04-24 09:31:46.716927818 +0000
@@ -132,7 +132,7 @@
     module_exists $modname || module_ret=$?

     if [ "$module_ret" -eq 0 ]; then
-       priority=$(sed -ne "s/^; priority=\([0-9]\+\)$/\\1/p" $source_ini)
+       priority=$(sed -ne "s/^;[ ]\?priority=\([0-9]\+\)$/\\1/p" $source_ini)
        [ -z "$priority" ] && priority=20
        echo $priority
        return 0


--- End Message ---
--- Begin Message ---
Version: 5.6.26+dfsg-1+rm

Dear submitter,

as the package php5 has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see https://bugs.debian.org/841781

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmas...@ftp-master.debian.org.

Debian distribution maintenance software
pp.
Scott Kitterman (the ftpmaster behind the curtain)

--- End Message ---

Reply via email to