Your message dated Sat, 05 Aug 2017 14:10:30 -0400
with message-id <>
and subject line hackrf tools fail to find connected hackrf
has caused the Debian Bug report #865719,
regarding hackrf tools fail to find connected hackrf
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: hackrf
Version: 2015.07.2-11+b2
Severity: normal

Dear Maintainer,

Ok, this is a problem that puzzles me.

I have a notebook with debian stretch. Plugged in the hackrf one and the hackrf 
tools worked
flawlessly out of the box. But that notebook is a bit slow.

So installed hackrf on my other notebook. Also strech.

The hackrf is recognized by the kernel:

[ 1006.723415] usb 1-1.1: new high-speed USB device number 10 using ehci-pci
[ 1006.833378] usb 1-1.1: New USB device found, idVendor=1d50, idProduct=6089
[ 1006.833384] usb 1-1.1: New USB device strings: Mfr=1, Product=2, 
[ 1006.833387] usb 1-1.1: Product: HackRF One
[ 1006.833390] usb 1-1.1: Manufacturer: Great Scott Gadgets
[ 1006.833392] usb 1-1.1: SerialNumber: 0000000000000000714465c82950364b

I can even load the hackrf kernel module, and it accesses the hackrf and outputs
it's firmware version while loading.

The dev node is created:

lrwxrwxrwx 1 root root 15 Jun 24 07:42 /dev/hackrf-one-1-1.1 -> bus/usb/001/010

Running as root should not be a permissions issue.

But still:

root@krup:~# hackrf_info 
hackrf_open() failed: HACKRF_ERROR_NOT_FOUND (-5)

looking at a strace (I'm no coder) I see that all usb devices are checked.

What could be the cause?


-- System Information:
Debian Release: 9.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_CH.UTF-8, LC_CTYPE=de_CH.UTF-8 (charmap=UTF-8), 
LANGUAGE=de_CH:de (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages hackrf depends on:
ii  libc6         2.24-11+deb9u1
ii  libhackrf0    2015.07.2-11+b2
ii  libusb-1.0-0  2:1.0.21-1

hackrf recommends no packages.

hackrf suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
The problem was unique to the submitter, who already
solved it.


--- End Message ---

Reply via email to