Your message dated Thu, 10 Aug 2017 19:30:59 +0200
with message-id <20170810173059.fisv43x5s7ih7...@roeckx.be>
and subject line Re: [Pkg-openssl-devel] Bug#871676: openssl: Asterisk-11.25.1 
failed to compile
has caused the Debian Bug report #871676,
regarding openssl: Asterisk-11.25.1 failed to compile
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
871676: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=871676
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: openssl
Version: 1.1.0f-4
Severity: normal

Dear Maintainer,

Trying to compile stock Asterisk 11.25.1 version on Stretch -even after having 
upgraded libssl and openssl to unstable 1.1.0f-4 version- it fail with 

   [CC] tcptls.c -> tcptls.o
tcptls.c: In function ‘tcptls_stream_close’:
tcptls.c:401:20: error: dereferencing pointer to incomplete type ‘SSL {aka 
struct ssl_st}’
    if (!stream->ssl->server) {
                    ^~
tcptls.c:404:5: warning: ‘ERR_remove_thread_state’ is deprecated 
[-Wdeprecated-declarations]
     ERR_remove_thread_state(NULL);
     ^~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/openssl/ct.h:13:0,
                 from /usr/include/openssl/ssl.h:61,
                 from /usr/src/asterisk-11.25.1/include/asterisk/tcptls.h:66,
                 from tcptls.c:44:
/usr/include/openssl/err.h:247:1: note: declared here
 DEPRECATEDIN_1_1_0(void ERR_remove_thread_state(void *))
 ^
tcptls.c: In function ‘__ssl_setup’:
tcptls.c:779:31: warning: implicit declaration of function 
‘SSLv2_client_method’ [-Wimplicit-function-declaration]
    cfg->ssl_ctx = SSL_CTX_new(SSLv2_client_method());
                               ^~~~~~~~~~~~~~~~~~~
tcptls.c:779:31: warning: passing argument 1 of ‘SSL_CTX_new’ makes pointer 
from integer without a cast [-Wint-conversion]
In file included from /usr/src/asterisk-11.25.1/include/asterisk/tcptls.h:66:0,
                 from tcptls.c:44:
/usr/include/openssl/ssl.h:1321:17: note: expected ‘const SSL_METHOD * {aka 
const struct ssl_method_st *}’ but argument is of type ‘int’
 __owur SSL_CTX *SSL_CTX_new(const SSL_METHOD *meth);
                 ^~~~~~~~~~~
tcptls.c:789:4: warning: ‘TLSv1_client_method’ is deprecated 
[-Wdeprecated-declarations]
    cfg->ssl_ctx = SSL_CTX_new(TLSv1_client_method());
    ^~~
In file included from /usr/include/openssl/ct.h:13:0,
                 from /usr/include/openssl/ssl.h:61,
                 from /usr/src/asterisk-11.25.1/include/asterisk/tcptls.h:66,
                 from tcptls.c:44:
/usr/include/openssl/ssl.h:1614:1: note: declared here
 DEPRECATEDIN_1_1_0(__owur const SSL_METHOD *TLSv1_client_method(void)) /* 
TLSv1.0 */
 ^
/usr/src/asterisk-11.25.1/Makefile.rules:143 : la recette pour la cible « 
tcptls.o » a échouée
make[1]: *** [tcptls.o] Erreur 1
Makefile:397 : la recette pour la cible « main » a échouée
make: *** [main] Erreur 2


-- System Information:
Debian Release: 9.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), 
LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages openssl depends on:
ii  libc6      2.24-11+deb9u1
ii  libssl1.1  1.1.0f-4

openssl recommends no packages.

Versions of packages openssl suggests:
ii  ca-certificates  20161130+nmu1

-- no debconf information

--- End Message ---
--- Begin Message ---
On Thu, Aug 10, 2017 at 05:36:19PM +0200, Tech wrote:
> Package: openssl
> Version: 1.1.0f-4
> Severity: normal
> 
> Dear Maintainer,
> 
> Trying to compile stock Asterisk 11.25.1 version on Stretch -even after 
> having upgraded libssl and openssl to unstable 1.1.0f-4 version- it fail with 

You either need to use a newer version of asterisk or build
against libssl1.0-dev


Kurt

--- End Message ---

Reply via email to