Your message dated Sat, 12 Aug 2017 06:51:59 -0400
with message-id <20170812105159.hkt4ro6d2czkh...@tc4.so-net.ne.jp>
and subject line ibus library transition problem
has caused the Debian Bug report #776560,
regarding ibus Japanese input fails using mozc
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
776560: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776560
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: ibus
Version: 1.5.9-1
Severity: important

Dear Maintainer,

I have ibus and mozc installed for Japanese input. While I can add them to
the menu successfully, when I try to switch input methods, the icon switches
to mozc, but Japanese input does not work.

I have tried this with anthy and have not been successful either. It seems
to be working fine when checking ~/.xsession-errors and when I use im-config.

-- Package-specific info:
default-display-manager: /usr/sbin/lightdm
ibus is /usr/bin/ibus
ibus-setup is /usr/bin/ibus-setup
im-config -l =>  ibus xim
im-config -m => default missing ibus
XMODIFIERS=@im=ibus
GTK_IM_MODULE=ibus
QT4_IM_MODULE=ibus
QT_IM_MODULE=xim
XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/:/usr/share
XDG_MENU_PREFIX=xfce-
PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

ls -l /usr/lib/ibus/
total 284
-rwxr-xr-x 1 root root  19088 Oct 22 06:12 ibus-dconf
-rwxr-xr-x 1 root root  10576 Oct 22 06:12 ibus-engine-simple
-rwxr-xr-x 1 root root 165048 Oct 22 06:12 ibus-ui-gtk3
-rwxr-xr-x 1 root root  89496 Oct 22 06:12 ibus-x11

-- System Information:
Debian Release: 8.0
  APT prefers testing-updates
  APT policy: (500, 'testing-updates'), (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.18-3.dmz.2-liquorix-amd64 (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages ibus depends on:
ii  dconf-cli                                    0.22.0-1
ii  dconf-gsettings-backend [gsettings-backend]  0.22.0-1
ii  gir1.2-gtk-3.0                               3.14.5-1
ii  gir1.2-ibus-1.0                              1.5.9-1
ii  gnome-icon-theme                             3.12.0-1
ii  libatk1.0-0                                  2.14.0-1
ii  libc6                                        2.19-13
ii  libcairo2                                    1.14.0-2.1
ii  libdconf1                                    0.22.0-1
ii  libgdk-pixbuf2.0-0                           2.31.1-2+b1
ii  libglib2.0-0                                 2.42.1-1
ii  libgtk-3-0                                   3.14.5-1
ii  libgtk2.0-0                                  2.24.25-1
ii  libibus-1.0-5                                1.5.9-1
ii  libnotify4                                   0.7.6-2
ii  libpango-1.0-0                               1.36.8-3
ii  libpangocairo-1.0-0                          1.36.8-3
ii  librsvg2-common                              2.40.5-1
ii  libx11-6                                     2:1.6.2-3
ii  libxi6                                       2:1.7.4-1+b2
ii  python-notify                                0.1.1-4
ii  python3-gi                                   3.14.0-1
pn  python3:any                                  <none>

Versions of packages ibus recommends:
ii  ibus-gtk   1.5.9-1
ii  ibus-gtk3  1.5.9-1
ii  ibus-qt4   1.3.2-2
ii  im-config  0.27-1

Versions of packages ibus suggests:
ii  ibus-clutter  0.0+git20090728.a936bacf-5.1+b1
ii  ibus-doc      1.5.9-1
ii  ibus-qt4      1.3.2-2
pn  libqt5gui5    <none>

-- Configuration Files:
/etc/X11/xinit/xinput.d/ibus e1d6b34d3391810daec087452e28badc [Errno 2] No such 
file or directory: u'/etc/X11/xinit/xinput.d/ibus 
e1d6b34d3391810daec087452e28badc'

-- no debconf information

--- End Message ---
--- Begin Message ---
Hi,

There were API breakage of ibus and binary update of mozc took time.

Yes, I should have bumped soname etc. when I uploaded newer version.
Blame me but that's history.

At least there is no problem with released versions.  So I am closing
this bug.

If youy still have problem, please reopen bug.

Thanks.

Osamu

--- End Message ---

Reply via email to