Your message dated Sat, 12 Aug 2017 16:38:00 +0000
with message-id <b6fcec60-9384-6c34-f973-6f40ce3b1...@thykier.net>
and subject line Re: [debhelper-devel] Bug#843769: debhelper: dgbsym package 
contains the wrong symbols
has caused the Debian Bug report #843769,
regarding debhelper: dbgsym package contains the wrong symbols
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
843769: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=843769
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: debhelper
Version: 10.2.2
Severity: normal

Dear Maintainer,

I tried to use the xca-dbgsym package and discovered that it contained the
wrong symbols.  The package uses a simple rules file that invokes all
default dh_* steps.

I analysed it in a chroot and came to the following conclusion:

1. the build ID of the xca binary (the only binary in the package) is
   736a4c65440b1dcfa898ca95a236c273dba8f06f

2. dh_strip created
   /usr/lib/debug/.build-id/04/a18d979aaa63ae0f23ecf5578b59b4369c29eb.debug

3. there is a binary called xca_db_stat in the build which is not contained
   in the binary package, but this binary has the build ID
   04a18d979aaa63ae0f23ecf5578b59b4369c29eb

It looks like dh_strip uses the wrong binary for extracting the debug
symbols.

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.8.4 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: systemd (via /run/systemd/system)

Versions of packages debhelper depends on:
ii  autotools-dev            20160430.1
ii  binutils                 2.27.51.20161105-2
ii  dh-autoreconf            12
ii  dh-strip-nondeterminism  0.028-1
ii  dpkg                     1.18.13
ii  dpkg-dev                 1.18.13
ii  file                     1:5.29-1
ii  libdpkg-perl             1.18.13
ii  man-db                   2.7.5-1
ii  perl                     5.24.1~rc3-3
ii  po-debconf               1.0.20

debhelper recommends no packages.

Versions of packages debhelper suggests:
pn  dh-make  <none>

-- debconf-show failed

--- End Message ---
--- Begin Message ---
On Wed, 12 Apr 2017 09:42:00 +0000 Niels Thykier <ni...@thykier.net> wrote:
> [...]
> 
> Hi Tino,
> 
> I just tried to reproduce this bug without success (amd64 using
> debhelper/10.2.3, dpkg-buildpackage -b).  [...]
> 
> I end up with *two* dbgsyms - one from xca and one from xca_db_stat.
> Both of which are in debian/xca/usr/bin/ at the time when dh_strip is
> called.
> 
> ...]
> 
> If you can still reproduce the issue, please provide the output of
> dh_strip -v [other arguments you use].  Keep in mind that dh_strip is a
> "destructive" operation, so you cannot just run it post build with -v.
> 
> Thanks,
> ~Niels
> 
> 
> 

Closing as non-reproducible.  You are more than welcome to reopen while
providing the additional information requested.

Thanks,
~Niels

--- End Message ---

Reply via email to