Your message dated Fri, 2 Feb 2018 17:44:44 +0100
with message-id <53e758bc-96a6-b8e2-dc07-c97b999d1...@debian.org>
and subject line Closing this bug
has caused the Debian Bug report #738863,
regarding openvswitch-switch: TCP does not work properly with virtio-net when 
3.12 kernel and tx/rx offloading is on
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
738863: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=738863
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: openvswitch-switch
Version: 1.9.3+git20131029-1.1
Severity: important

Dear Maintainer,

   * What led up to the situation?

I ran apt-get upgrade/aptitude safe-upgrade on the host to upgrade my testing 
box to latest testing packages.

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

After installing the latest 3.12 kernel (linux-image-3.12-1-amd64, version 
3.12.9-1) from testing causes TCP connections to stop working on qemu/kvm 
connected to openvswitch by way of a virtio-net tap 
device.  Packet traces show lots of TCP retransmission errors.  Very 
occasionally a TCP connection works, but is dropped soon after.  Most often the 
connection stops working entirely.

If I run the command:
ethtool -K <virtio-net tap device> tso off gro off gso off tx off rx off

everything starts working again.

Going back to 3.11 kernel also makes things work.

   * What was the outcome of this action?

Using 3.12 kernel from testing causes TCP connections to stop working on 
qemu/kvm guests and generates large numbers of TCP retransmission errors

   * What outcome did you expect instead?

Using 3.12 kernel from testing should not break TCP connections on qemu/kvm 
guests



-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.12-1-amd64 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

--- End Message ---
--- Begin Message ---
Since this is a kernel bug, and that we're not even shipping this
version 3.12 in Debian (Wheezy has 3.2, Jessie has 3.16), this bug can
be closed.

Cheers,

Thomas Goirand (zigo)

--- End Message ---

Reply via email to