Your message dated Sun, 04 Feb 2018 15:06:28 +0000
with message-id <e1eilsc-0005s1...@fasolo.debian.org>
and subject line Bug#870538: fixed in libee 0.4.1-1.2
has caused the Debian Bug report #870538,
regarding libee: hardcoded Pre-Depends on multiarch-support
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
870538: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870538
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: libee
Version: 0.4.1-1.1
Tags: sid buster patch
User: debian-gl...@lists.debian.org
Usertags: multiarch-support-removal

Dear Maintainer,

The multiarch-support package has been introduced with squeeze so that
packages using the multiarch libraries can Pre-Depends on it to make
sure the multiarch path ares supported by the dynamic linker. As
dist-upgrades from such a distant release are not supported, the
Pre-Depends can now be dropped and then the package removed from the
archive.

Most of the packages added this Pre-Depends through debhelper and the
misc:Pre-Depends substvar, so a change in debhelper [1] was enough to
get rid of it. However it appears that your package uses a hardcoded
Pre-Depends, thus it needs to be removed manually. You will find a
patch attached to do so.

Please apply it as soon as possible as the multiarch-support package
will be removed from the archive for buster. Failing to do so will 
therefore make your package uninstallable. In case you don't have
time to do so, don't hesitate to ask for a NMU.

Thanks,
Aurelien

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783898
diff -Nru libee-0.4.1/debian/control libee-0.4.1/debian/control
--- libee-0.4.1/debian/control	2014-06-05 12:59:17.000000000 +0000
+++ libee-0.4.1/debian/control	2017-08-02 19:31:27.000000000 +0000
@@ -28,7 +28,7 @@
 Section: libs
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
 Description: Event expression library inspired by CEE
  Libee is an event expression library which is inspired by the upcoming
  CEE standard. It provides capabilities to generate and emit messages in

--- End Message ---
--- Begin Message ---
Source: libee
Source-Version: 0.4.1-1.2

We believe that the bug you reported is fixed in the latest version of
libee, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 870...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aurelien Jarno <aure...@debian.org> (supplier of updated libee package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sat, 20 Jan 2018 14:16:39 +0100
Source: libee
Binary: libee-dev libee0
Architecture: source
Version: 0.4.1-1.2
Distribution: unstable
Urgency: medium
Maintainer: Pierre Chifflier <pol...@debian.org>
Changed-By: Aurelien Jarno <aure...@debian.org>
Description:
 libee-dev  - Event expression library inspired by CEE
 libee0     - Event expression library inspired by CEE
Closes: 870538
Changes:
 libee (0.4.1-1.2) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * debian/control: Drop explicit Pre-Depends on multiarch-support (Closes:
     #870538).
Checksums-Sha1:
 e4282be6fff330db032a17af0da6a9bfebe3e698 1802 libee_0.4.1-1.2.dsc
 f4acbe1d869db9bbded2d883e7e855dc2c4a973e 3192 libee_0.4.1-1.2.debian.tar.xz
 5c7dc5cf4da1f484cd518fc76ac997335544372e 5313 libee_0.4.1-1.2_source.buildinfo
Checksums-Sha256:
 baaac0f43ac3c575dc314a8a103901a1ccdbb9aaecd53ca360e38e9b5e916852 1802 
libee_0.4.1-1.2.dsc
 c4625f7088524153f69a6c138927af588cf4ed8df47e27e22755f6b52de216c7 3192 
libee_0.4.1-1.2.debian.tar.xz
 3d56895c19ab658e05ebb3e3da3b168aade4166143d6470547facbec80e2464f 5313 
libee_0.4.1-1.2_source.buildinfo
Files:
 16fb7c59ab83b6bb414d66b64fccab9b 1802 libs extra libee_0.4.1-1.2.dsc
 8780e433b12cd0d1a8ebda0c38217922 3192 libs extra libee_0.4.1-1.2.debian.tar.xz
 d65321689e29c2e5f0cc5f7ba3cbebca 5313 libs extra 
libee_0.4.1-1.2_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEUryGlb40+QrX1Ay4E4jA+JnoM2sFAlpjQXMACgkQE4jA+Jno
M2s2Og/8D0gjxzg8T+zV7LXwhPKJiyiC7Mgpqkad4jT9e7h5AYwhVhJOEavhbBE+
83Es8dh8qP6bHNQ0ibo3HgFGIM3kLIuFFuRHsy495/xMqGh3wuvyISspWr0BC320
U8yISvaPj98dZC+UABqHGLNWEFiJfU9mhJk9dPxO6UFPD/qvbPs/L6u4HLrcdmUQ
57Wt/o/zKKm4FIDv1YL9oDsxgGqq5WBU07ljoP37GKnRxLw+0XRKbY5p6Q8CBGMn
+O4eZmhu8kjsgH1HbwI+ByzvD5Cch7CD1kccSQh7mFi3LvXotCszrr0f4fmpRTGI
RlaCT9JKy1IjOrtkxzNi7mzprqBDupTOPmamlvMIlOyRChLIbNeGDaiUAvbFToSB
cRN/dmMxHMz4V279DpekjYKcBGeauHwhFlzok3zXqPoYyV2ZqMcuuVG/QuQYQ0Wm
Jt+F67BXvA56rIILI9gsvKx9tNQlTA6h/DDcm4hrHPgTL6QZhDQh67fh5cBALIo/
tChB05giJ8SnVm/I21q4cFQo5WeAg4ChrbDyjrDbAa5LwDBc2e4rsbwk9+dAwebM
WfdW5A9GidU9fKuc8EN52QeukT0XafD3h9ib3sYFyxX0RlOHPXa4yeNh6jJjwgwm
BlQ4MNjwnloJUpd+sleG6q9i5QbGczaw8yG7FwbzyIqEgNsRFhY=
=pHGk
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to