Your message dated Sun, 04 Feb 2018 21:19:53 +0000
with message-id <e1eirhz-000d70...@fasolo.debian.org>
and subject line Bug#870548: fixed in lua-cjson 2.1.0+dfsg-2.1
has caused the Debian Bug report #870548,
regarding lua-cjson: hardcoded Pre-Depends on multiarch-support
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
870548: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870548
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: lua-cjson
Version: 2.1.0+dfsg-2
Tags: sid buster patch
User: debian-gl...@lists.debian.org
Usertags: multiarch-support-removal

Dear Maintainer,

The multiarch-support package has been introduced with squeeze so that
packages using the multiarch libraries can Pre-Depends on it to make
sure the multiarch path ares supported by the dynamic linker. As
dist-upgrades from such a distant release are not supported, the
Pre-Depends can now be dropped and then the package removed from the
archive.

Most of the packages added this Pre-Depends through debhelper and the
misc:Pre-Depends substvar, so a change in debhelper [1] was enough to
get rid of it. However it appears that your package uses a hardcoded
Pre-Depends, thus it needs to be removed manually. You will find a
patch attached to do so.

Please apply it as soon as possible as the multiarch-support package
will be removed from the archive for buster. Failing to do so will 
therefore make your package uninstallable. In case you don't have
time to do so, don't hesitate to ask for a NMU.

Thanks,
Aurelien

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783898
diff -Nru lua-cjson-2.1.0+dfsg/debian/control lua-cjson-2.1.0+dfsg/debian/control
--- lua-cjson-2.1.0+dfsg/debian/control	2012-08-24 13:21:32.000000000 +0000
+++ lua-cjson-2.1.0+dfsg/debian/control	2017-08-02 19:31:56.000000000 +0000
@@ -12,7 +12,7 @@
 Package: lua-cjson
 Architecture: any
 Multi-Arch: same
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
 Depends: ${misc:Depends}, ${shlibs:Depends}
 Provides: ${lua:Provides}
 XB-Lua-Versions: ${lua:Versions}
@@ -29,7 +29,7 @@
 Section: libdevel
 Architecture: any
 Multi-Arch: same
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
 Depends: ${misc:Depends}, ${shlibs:Depends}, lua-cjson (= ${binary:Version})
 Provides: ${lua:Provides}
 XB-Lua-Versions: ${lua:Versions}

--- End Message ---
--- Begin Message ---
Source: lua-cjson
Source-Version: 2.1.0+dfsg-2.1

We believe that the bug you reported is fixed in the latest version of
lua-cjson, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 870...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aurelien Jarno <aure...@debian.org> (supplier of updated lua-cjson package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sat, 20 Jan 2018 21:15:36 +0100
Source: lua-cjson
Binary: lua-cjson lua-cjson-dev
Architecture: source
Version: 2.1.0+dfsg-2.1
Distribution: unstable
Urgency: medium
Maintainer: The Debian Lua Team <pkg-lua-de...@lists.alioth.debian.org>
Changed-By: Aurelien Jarno <aure...@debian.org>
Description:
 lua-cjson  - JSON parser/encoder for Lua
 lua-cjson-dev - JSON parser/encoder for Lua, development files
Closes: 870548
Changes:
 lua-cjson (2.1.0+dfsg-2.1) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * debian/control: Drop explicit Pre-Depends on multiarch-support
     (Closes: #870548).
Checksums-Sha1:
 76a4abed117f3812f5be57c52795e67f4e19e1d6 2077 lua-cjson_2.1.0+dfsg-2.1.dsc
 26cf5b0172ab77955c34527db2f5090542bd78a0 3636 
lua-cjson_2.1.0+dfsg-2.1.debian.tar.xz
 c96afa776442f38623c4b5af873ce17bd127d42d 5802 
lua-cjson_2.1.0+dfsg-2.1_source.buildinfo
Checksums-Sha256:
 ad22266d787af3cb06d53de7068344a3e4c5de45da6ff5c6e88d95b60a992c08 2077 
lua-cjson_2.1.0+dfsg-2.1.dsc
 a258cf10caf261e9b5cba647bd74f659ddb6c6dec1e16b521a0a37c384fad0f1 3636 
lua-cjson_2.1.0+dfsg-2.1.debian.tar.xz
 3f3f0eb806e1005569bcff3a9cde21959dcda3858d7baa9d86584e7788e6655a 5802 
lua-cjson_2.1.0+dfsg-2.1_source.buildinfo
Files:
 08dce0d0a01a9549928ab13c5b9ad2d4 2077 interpreters optional 
lua-cjson_2.1.0+dfsg-2.1.dsc
 16129dc8aa8e81da87def81e3e6ce08b 3636 interpreters optional 
lua-cjson_2.1.0+dfsg-2.1.debian.tar.xz
 a0169256e90136a78a06c27cf77e696d 5802 interpreters optional 
lua-cjson_2.1.0+dfsg-2.1_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEUryGlb40+QrX1Ay4E4jA+JnoM2sFAlpjo4UACgkQE4jA+Jno
M2vFzg/8DHTTchpssmutsqj5q1nBnGzNrhJG0hHe/IXmfE/sa883iMg4OVJdTr7E
KjeZcW1mYMc5fwnE76kkwnIXMHGjWo+l+GzFIoDsQX8g4GuuuMk1BHd6utelm3ff
AIYIWCglawCoQKwmLOtnCPiVwPiVj4wPhUq2UfzlSCcL8PQ3UbqpltMvF3NgsxRp
0f7+VXYnt1VZv5XD7htTmi4EFzaB3yRBZX+rU0MHn5cbu9KcdajUy1Y54SfSFUIe
q66oS3n/dPvIDm0edvWAHfryT0MdyPbLBJLnb8eXtuScsa+oc1Zo4VF6bf+XIX+U
6Q/xDupzRGeWlxZMKX+FYnv0z171ldnGrXRSUOxM3zHcWkmpQndwoKSQy/PHfUG/
Z4waNbzluFQD2b3WzX8QtyqJQ55qcNYcr+QmyTwHil0RkV331RYRhRUuFjBvBszM
kfbKquB4us9RsrTsYbz7MlrgQOYAbXsA09eDdZXRgcH3gvUUf7rtfE5x1gCx/fCi
ztKX2QWgf4d+f85UcQO8GolRlDwMbdub27XF3eGKsbLecB7AUhF4rvkQq4+cTXEd
LeJWWAR8ipAWcdn+5Tq7JKijOfkqISiTk8Fkj5vhE5NEOUlr9YHIfThLVTLtbwYc
zLeBnFH8ffZZcHbiMQlwzpFVubu0FRfGrvLBthmoKj/rPqFmEuQ=
=iFfC
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to