Your message dated Sun, 04 Feb 2018 22:28:26 +0000
with message-id <e1eislu-0003kj...@fasolo.debian.org>
and subject line Bug#870557: fixed in lua-zlib 0.2+git+1+9622739-2.1
has caused the Debian Bug report #870557,
regarding lua-zlib: hardcoded Pre-Depends on multiarch-support
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
870557: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870557
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: lua-zlib
Version: 0.2+git+1+9622739-2
Tags: sid buster patch
User: debian-gl...@lists.debian.org
Usertags: multiarch-support-removal

Dear Maintainer,

The multiarch-support package has been introduced with squeeze so that
packages using the multiarch libraries can Pre-Depends on it to make
sure the multiarch path ares supported by the dynamic linker. As
dist-upgrades from such a distant release are not supported, the
Pre-Depends can now be dropped and then the package removed from the
archive.

Most of the packages added this Pre-Depends through debhelper and the
misc:Pre-Depends substvar, so a change in debhelper [1] was enough to
get rid of it. However it appears that your package uses a hardcoded
Pre-Depends, thus it needs to be removed manually. You will find a
patch attached to do so.

Please apply it as soon as possible as the multiarch-support package
will be removed from the archive for buster. Failing to do so will 
therefore make your package uninstallable. In case you don't have
time to do so, don't hesitate to ask for a NMU.

Thanks,
Aurelien

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783898
diff -Nru lua-zlib-0.2+git+1+9622739/debian/control lua-zlib-0.2+git+1+9622739/debian/control
--- lua-zlib-0.2+git+1+9622739/debian/control	2014-08-31 16:58:46.000000000 +0000
+++ lua-zlib-0.2+git+1+9622739/debian/control	2017-08-02 19:32:27.000000000 +0000
@@ -11,7 +11,7 @@
 Package: lua-zlib
 Architecture: any
 Multi-Arch: same
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
 Depends: ${shlibs:Depends}, ${misc:Depends}
 Provides: ${lua:Provides}
 XB-Lua-Versions: ${lua:Versions}
@@ -22,7 +22,7 @@
 Package: lua-zlib-dev
 Architecture: any
 Multi-Arch: same
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
 Section: libdevel
 Depends: lua-zlib (= ${binary:Version}), ${misc:Depends}
 Provides: ${lua:Provides}

--- End Message ---
--- Begin Message ---
Source: lua-zlib
Source-Version: 0.2+git+1+9622739-2.1

We believe that the bug you reported is fixed in the latest version of
lua-zlib, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 870...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aurelien Jarno <aure...@debian.org> (supplier of updated lua-zlib package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sat, 20 Jan 2018 22:12:35 +0100
Source: lua-zlib
Binary: lua-zlib lua-zlib-dev
Architecture: source
Version: 0.2+git+1+9622739-2.1
Distribution: unstable
Urgency: medium
Maintainer: Enrico Tassi <gareuselesi...@debian.org>
Changed-By: Aurelien Jarno <aure...@debian.org>
Description:
 lua-zlib   - zlib library for the Lua language
 lua-zlib-dev - zlib development files for the Lua language
Closes: 870557
Changes:
 lua-zlib (0.2+git+1+9622739-2.1) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * debian/control: Drop explicit Pre-Depends on multiarch-support
     (Closes: #870557).
Checksums-Sha1:
 0ad2be3efb591a9a8ad193a8cc01bd55039f7017 2005 
lua-zlib_0.2+git+1+9622739-2.1.dsc
 d88f80fff1adabb569a42cb7d9f24dded46d68d3 2744 
lua-zlib_0.2+git+1+9622739-2.1.debian.tar.xz
 ab19040fe2f1be3124b4010adc0fd06ebee8af4a 5856 
lua-zlib_0.2+git+1+9622739-2.1_source.buildinfo
Checksums-Sha256:
 2161c7d982833a8513fc43d1c5e129507482d18de688cdf4fd88877133a77807 2005 
lua-zlib_0.2+git+1+9622739-2.1.dsc
 685c6e06c8cee9410dfca278ce45cb983d7a6b7b18963dd0272cec8b47105968 2744 
lua-zlib_0.2+git+1+9622739-2.1.debian.tar.xz
 d3bee63cca15bd5f250dcf925dbacc200c54af5f1a65260e41271aa1502b780d 5856 
lua-zlib_0.2+git+1+9622739-2.1_source.buildinfo
Files:
 12663f90eb053498c1a268e1ea271972 2005 interpreters optional 
lua-zlib_0.2+git+1+9622739-2.1.dsc
 4ffbf5791983743070bf6ea6850a2f69 2744 interpreters optional 
lua-zlib_0.2+git+1+9622739-2.1.debian.tar.xz
 cb792aec8b37e48c334228256c54277d 5856 interpreters optional 
lua-zlib_0.2+git+1+9622739-2.1_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEd0YmQqnvlP0Pdxltupx4Bh3djJsFAlpjsRQACgkQupx4Bh3d
jJtl9A//T/llsLA2M/3hroopduJNP4M40dPoIBIoJE7DhoO66igpk7VeCVJ4oDIt
XbUhOYOHWPERcEwMEfN+Omk2Ekmqm7Cvg482RBIv9A0AKmI7+9mUud7AN1sn5bAf
Rxh+/sQoSLI43+NZ+paVYtBS2U+SF78vLxsJMmJTTVbAKKFMf9VDidB8Aza4P4y6
at3naXcACwV/EjLRrzRJbIK+9LZsn4fZlGzgbPYnoTq5mqjW1yYG5l9fIT7y2+n8
UE3A7YuD6WsBhr7iOkkcUsP6S/KtVgtvo4/hV3EOy004WNW2ThTywtPmhD0xC2YY
FhDr0MTYf11EcEYLp7zyNa+gk4yQLZcQuXiD6JUsTTipUgMcIrTZgUdm4FIqMGoj
K/iag82wQ0WV2h0tV9hSowohtk37ycrqrXedTciwuGmwjTuiQLKwl96+PMUGY9iT
4aLLlxuHHNJVYmCQXkCAeoy9INkRJY01TCngTQk4NMv0tTWTN1X2OS2CiEzv7P81
W5e0HsUsoNUWIK+TAto8L3WrMhK71ZHU8nvMknkdMxEo2PkIhvJUteFdV1/26pwI
HdRR+1QHNsLjta4iAeyLf5WlHBQdvPUsrzJr2tjxZuR+7fwhSn1nMn3TRk7aD2vd
++jsfUWehiG5keDLmABDVjrCm2AS48LWyAsKsFXAHaX7LU4wadI=
=Qep6
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to