Your message dated Sun, 04 Feb 2018 22:28:13 +0000
with message-id <e1eislh-0003hx...@fasolo.debian.org>
and subject line Bug#870555: fixed in lua-svn 0.4.0-9.1
has caused the Debian Bug report #870555,
regarding lua-svn: hardcoded Pre-Depends on multiarch-support
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
870555: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870555
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: lua-svn
Version: 0.4.0-9
Tags: sid buster patch
User: debian-gl...@lists.debian.org
Usertags: multiarch-support-removal

Dear Maintainer,

The multiarch-support package has been introduced with squeeze so that
packages using the multiarch libraries can Pre-Depends on it to make
sure the multiarch path ares supported by the dynamic linker. As
dist-upgrades from such a distant release are not supported, the
Pre-Depends can now be dropped and then the package removed from the
archive.

Most of the packages added this Pre-Depends through debhelper and the
misc:Pre-Depends substvar, so a change in debhelper [1] was enough to
get rid of it. However it appears that your package uses a hardcoded
Pre-Depends, thus it needs to be removed manually. You will find a
patch attached to do so.

Please apply it as soon as possible as the multiarch-support package
will be removed from the archive for buster. Failing to do so will 
therefore make your package uninstallable. In case you don't have
time to do so, don't hesitate to ask for a NMU.

Thanks,
Aurelien

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783898
diff -Nru lua-svn-0.4.0/debian/control lua-svn-0.4.0/debian/control
--- lua-svn-0.4.0/debian/control	2013-08-12 12:18:13.000000000 +0000
+++ lua-svn-0.4.0/debian/control	2017-08-02 19:32:21.000000000 +0000
@@ -11,7 +11,7 @@
 Package: lua-svn
 Architecture: any
 Multi-Arch: same
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
 Depends: ${shlibs:Depends}, ${misc:Depends}, lua-expat, lua-socket
 Provides: ${lua:Provides}
 XB-Lua-Versions: ${lua:Versions}
@@ -21,7 +21,7 @@
 Package: lua-svn-dev
 Architecture: any
 Multi-Arch: same
-Pre-Depends: multiarch-support
+Pre-Depends: ${misc:Pre-Depends}
 Depends: lua-svn (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
 Section: libdevel
 Provides: ${lua:Provides}

--- End Message ---
--- Begin Message ---
Source: lua-svn
Source-Version: 0.4.0-9.1

We believe that the bug you reported is fixed in the latest version of
lua-svn, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 870...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aurelien Jarno <aure...@debian.org> (supplier of updated lua-svn package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sat, 20 Jan 2018 21:47:42 +0100
Source: lua-svn
Binary: lua-svn lua-svn-dev
Architecture: source
Version: 0.4.0-9.1
Distribution: unstable
Urgency: medium
Maintainer: Enrico Tassi <gareuselesi...@debian.org>
Changed-By: Aurelien Jarno <aure...@debian.org>
Description:
 lua-svn    - Subversion library for the Lua language
 lua-svn-dev - Development files for the Subversion library for the Lua language
Closes: 870555
Changes:
 lua-svn (0.4.0-9.1) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * debian/control: Drop explicit Pre-Depends on multiarch-support
     (Closes: #870555).
Checksums-Sha1:
 b78e166a0d9fc49b1bbc2b834fac53dcbf798d15 1966 lua-svn_0.4.0-9.1.dsc
 e9a0e9cb7fc75aadb72ab3e70edab37cd9b3b3a4 3984 lua-svn_0.4.0-9.1.debian.tar.xz
 5c2ae35e95e01de3d4262d27e07714a8cdf6c816 7515 
lua-svn_0.4.0-9.1_source.buildinfo
Checksums-Sha256:
 5cccf78d66b5d4144e93b69d90f5ae0cb83e21b9744bf9043e96dee00554ce28 1966 
lua-svn_0.4.0-9.1.dsc
 0bcdba9c061b33e558b1d601d94d984bfe4c7be046458c42f82e4da1c6e8ce0c 3984 
lua-svn_0.4.0-9.1.debian.tar.xz
 83341e2edff1e142b8e6e0168c66fd3f5109801c33747d62a613f9e710648f70 7515 
lua-svn_0.4.0-9.1_source.buildinfo
Files:
 d22eebd00153021c84a9387a8a2ec130 1966 interpreters optional 
lua-svn_0.4.0-9.1.dsc
 d1964d970f522e27be72a9dae63f12af 3984 interpreters optional 
lua-svn_0.4.0-9.1.debian.tar.xz
 f3f2cd0a3f71883ead7fb23c856c7192 7515 interpreters optional 
lua-svn_0.4.0-9.1_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEd0YmQqnvlP0Pdxltupx4Bh3djJsFAlpjsKQACgkQupx4Bh3d
jJvWdg//ZYCfL6Xk1fZJR1GJ4rCJTm3WNfVCnf3i/ZiNWisveVoj60oQKy5iSIKY
QxYJJHz997xnKzZlHXQIMMvBLHp0dYqj7vmtrk57V7PCyiVQefQYRcHA5J0XB+tY
TjnqYzV0mIzEXvHHjhhLlGJHRcdIjHlA/aQ0cQjjkblO0wv58ylm26MIqLEaSTJT
8On2OwAi0hm2jReBqkQBVGoaeZR+DZQzsYPJOnoIeaoJZWtp4kjSnpLZEEUlLu5/
pj0RFnpBSGtG8S2ytwnxZDeMwWwT9eWlLypDkGwKAMuyT+kGWBHyxzUxDeM3/XIx
oN2VTZK4IjW/6gxWMIMXR6Y+1HU3j/uliEbWGuyKPiJF2I5u4Px3EpcwiJY3PPTM
MaHX1E41r5CEQckBITkkEsQd0U/nxuHFzvIDC5uCrZM+agl0/RiRdm1F+asCADsj
CFZAiNipPvBPx2kqxMjeSwkry9e+GkvMdV2wDoBZymTVtBEeXKWSmaTEBmiRrCgc
l77T2vffXcL1WuK4p83f8ppFW3lf5XoKi3+111YOiucecKnFrBRJ75CaUN2vEBXL
vuyB6T1tt42Bn/mTQpPivBjZWTJgRm61lU5J41CsmAep5MrpNYsReZ9E+CGGVSuk
QtRI6Ypm3MR/kUhR7YP9wK0b7+b7nK+NUN23Grc9jExbGZO5qfI=
=pPNo
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to