Your message dated Wed, 14 Feb 2018 21:19:45 +0000
with message-id <e1em4sv-000eoy...@fasolo.debian.org>
and subject line Bug#886454: fixed in phppgadmin 5.1+ds-3
has caused the Debian Bug report #886454,
regarding pg_dump: invalid option -- 'i'
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
886454: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=886454
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: phppgadmin
Version: 5.1-1.1

Date: Sat, 6 Jan 2018 06:20:56 +0100
From: roger21 <roge...@free.fr>
To: pkg-postgresql-pub...@lists.alioth.debian.org
Subject: [Pkg-postgresql-public] bug in the export feature of phpPgAdmin

Hi,

i can't do a descent bug report but still i'm trying to report that :

the export feature of phpPgAdmin fails since it uses an obsolete parameter
(-i) for pg_dump as reported by the apache/php error log :


error.log:/usr/lib/postgresql/9.6/bin/pg_dump: invalid option -- 'i'
error.log:Try "pg_dump --help" for more information.


the bug is in the file /usr/share/phppgadmin/dbexport.php :

at line 76 :

$cmd = $exe . " -i";"

must be replaced by :

"$cmd = $exe;"

the -i parameters does not need to be replaced by anything.


the bug is well known, there are even youtube video about the fix ...


the phpPgAdmin development seems discontinued but i hope this could be patched
since it is so minor.


cheers

--- End Message ---
--- Begin Message ---
Source: phppgadmin
Source-Version: 5.1+ds-3

We believe that the bug you reported is fixed in the latest version of
phppgadmin, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 886...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jean-Michel Vourgère <nir...@debian.org> (supplier of updated phppgadmin 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Wed, 14 Feb 2018 20:52:56 +0000
Source: phppgadmin
Binary: phppgadmin
Architecture: source all
Version: 5.1+ds-3
Distribution: unstable
Urgency: medium
Maintainer: Debian PostgreSQL Maintainers 
<pkg-postgresql-pub...@lists.alioth.debian.org>
Changed-By: Jean-Michel Vourgère <nir...@debian.org>
Description:
 phppgadmin - web-based administration tool for PostgreSQL
Closes: 886446 886454
Changes:
 phppgadmin (5.1+ds-3) unstable; urgency=medium
 .
   [ Christoph Berg ]
   * Move packaging repository to salsa.debian.org
 .
   [ Jean-Michel Vourgère ]
   * Bumped policy to 4.1.3: Priority is now optional.
   * Bumped compat to 11.
   * Fix exports with new patch fix-obsolete-pgdump-flag to remove -i option
     from pg_dump calls. Thanks to roger21. Closes: #886454
   * Add support for postgres version with 2 digits with patch
     2digit-pg-versions. Closes: #886446
Checksums-Sha1:
 f0d093c6d0dec5990118c9eb80292b66dc13e2ee 2022 phppgadmin_5.1+ds-3.dsc
 de5618c7d0c3d0bc0dd4b8ad1775687084b198c9 11908 
phppgadmin_5.1+ds-3.debian.tar.xz
 8c308501aa7620273c5e6f1e37db20a1c350ed9c 450228 phppgadmin_5.1+ds-3_all.deb
 1a0b0e34cda431c778fd74669460f2567d212e3f 5967 
phppgadmin_5.1+ds-3_amd64.buildinfo
Checksums-Sha256:
 8a2b6d37d9ea350a5aa11cc55f29126ad20947f8c75a3bf8b27d21b6ec9be0a2 2022 
phppgadmin_5.1+ds-3.dsc
 42cc5bf1c4b54a71d0fe2e00aad43d31a8134ee00cec73815a18f8762806c191 11908 
phppgadmin_5.1+ds-3.debian.tar.xz
 6277d8ec43e6c88944c81f7af0662ee0570be4113970092c3b087c4e7830db97 450228 
phppgadmin_5.1+ds-3_all.deb
 3779c43a09f7663a493d9806546687d001140ec79974d7d94cfbbec961af24e2 5967 
phppgadmin_5.1+ds-3_amd64.buildinfo
Files:
 b44dde2e3ff3a1dc1425abcc39ee150f 2022 web optional phppgadmin_5.1+ds-3.dsc
 dd72fa0a7f620b621ece8fa6bd37f6cc 11908 web optional 
phppgadmin_5.1+ds-3.debian.tar.xz
 98813284c80adea945cd85533a5526ab 450228 web optional 
phppgadmin_5.1+ds-3_all.deb
 a8fe137a17c953bb9659cf8dfdae0f5a 5967 web optional 
phppgadmin_5.1+ds-3_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQJGBAEBCAAwFiEEQIMD57NJdABlZVMrO1wscaIY2DwFAlqEor8SHG5pcmdhbEBk
ZWJpYW4ub3JnAAoJEDtcLHGiGNg8vk8P/R8rwJPonE2SfekQ3sNEaiQVOCyfvwpo
dyFTJd1s36b4Wm5UyD0k0LjUyfJQv3MOzCqvALg3hmohDJNBt8T2d4Hj7Of63U1+
joZRsLcJVdyN18NQTfipMcq3BAA4FgLGLwjQcF33F/e1MSSPOh2qgf4qWuxAO+lT
+ztj42fid2+cT6MuubR5V8Z+jWy9ADJGf3DB/1mjKARq7JZWOGhdAgnJdCp8+F/Y
BTl2HKO6Nq4XhhThojZIEAPM99PdmoJgjScrpsrpbNsVFw7aDhFWM1dPG2W4oK4k
weHxsOnbvlgljOcBpsV/z3x0US9kDN5LeVLJPx12gnA0qNnrD8kSdjH6e5oUL7n3
EK/qYJ7LCQoHUnq6SE2KpEt/WGDje6p8DrK6iWDO3QzE8IaZ5yzgqN/006+wwD2T
22HVptG4wU5v494uvnK+l8vbpxN1pVWujaq+S2a0DMm22pu3URc8DyIej1QgHFdQ
QRdkQF3RgF1Gpy26+7vxkJ+FVe7jVQvqhZu5v15QR1C7MC7OSc27tvKMeb2mFFt3
hwaIww2xVbprnFCgOvJs2uUCHWr/OJs2XloMa5188Xh9TjqjWwzeMABHdaMBqoS9
y5rCAoPVFkHnrnGe6k/3w5tzcFhhzrxQSLmOYuQROQIRVXfhO9iawsF9OW1ICjeZ
TW6CjnAtwYj6
=JVP+
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to