Your message dated Thu, 22 Feb 2018 09:00:11 +0100
with message-id 
<caatjj0lpumn1woocncitdfuz4iy697rjwb-dqm9gdx_rkap...@mail.gmail.com>
and subject line found 888955 - is the same, closing this one
has caused the Debian Bug report #891071,
regarding Race on startup can let the service completely fail
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
891071: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891071
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: open-vm-tools
Version: 2:10.2.0-3

Hi,
I've got reported issues which looked like a failed to start service
on boot with:
   Active: failed (Result: resources)

A restart on the system after boot worked.

The actual issue was eventually to be found as: "Read-only file system".
After a while I realized we essentially hit [1].

Since [2] the service sets DefaultDependencies=no
But OTOH we use "PrivateTmp=yes" which needs writable /var/tmp.

The combination of the above without precaution is the issue as it may
be started before all file systems are up.

I propose a change to the dependencies that in all my tests worked fine with:
1. still being before cloud-init
2. the file system being ready and no more hitting the issue

--- a/debian/open-vm-tools.service
+++ b/debian/open-vm-tools.service
@@ -4,6 +4,7 @@ Documentation=http://open-vm-tools.sourceforge.net/about.php
ConditionVirtualization=vmware
DefaultDependencies=no
Before=cloud-init-local.service
+After=local-fs.target

[Service]
ExecStart=/usr/bin/vmtoolsd



[1]: 
https://github.com/systemd/systemd/blob/2e6dbc0fcd45c152f15aed77cde4fd07957c150c/src/core/service.c#L1832
[2]: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=859677

-- 
Christian Ehrhardt
Software Engineer, Ubuntu Server
Canonical Ltd

--- End Message ---
--- Begin Message ---
Sorry,
I saw too late that we already had a bug on this.
I'll chime in there, closing this one.


-- 
Christian Ehrhardt
Software Engineer, Ubuntu Server
Canonical Ltd

--- End Message ---

Reply via email to