Your message dated Fri, 2 Mar 2018 20:11:09 +0100
with message-id <20180302191108.ga11...@s.cotton.clara.co.uk>
and subject line Re: Bug#852026: mate_invest: causes "Could not load the 
stocks" error in pydoc -k
has caused the Debian Bug report #852026,
regarding mate_invest: causes "Could not load the stocks" error in pydoc -k
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
852026: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=852026
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: mate-applets
Version: 1.16.0-1
Severity: normal

Doing a keyword search with pydoc results in an error message from the 
mate-invest applet's
/usr/lib/python2.7/dist-packages/mate_invest/__init__.py

$ pydoc -k datetime
datetime - Fast implementation of the datetime type.
2017-01-20 20:47:57.285987: ERROR: Could not load the stocks from 
/home/steve/.config/mate/invest-applet/stocks.pickle: [Errno 2] No such file or 
directory: '/home/steve/.config/mate/invest-applet/stocks.pickle'
zope.interface.common.idatetime - Datetime interfaces.
zope.interface.common.tests.test_idatetime - Test for datetime interfaces

$ pydoc -k any_search_term
2017-01-20 20:48:11.117224: ERROR: Could not load the stocks from 
/home/steve/.config/mate/invest-applet/stocks.pickle: [Errno 2] No such file or 
directory: '/home/steve/.config/mate/invest-applet/stocks.pickle'

-- System Information:
Debian Release: 9.0
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages mate-applets depends on:
ii  gir1.2-mate-panel          1.16.0-1
ii  gsettings-desktop-schemas  3.22.0-1
ii  gvfs                       1.30.3-1
ii  libatk1.0-0                2.22.0-1
ii  libc6                      2.24-9
ii  libcairo-gobject2          1.14.8-1
ii  libcairo2                  1.14.8-1
ii  libcpufreq0                008-1
ii  libdbus-1-3                1.10.14-1
ii  libdbus-glib-1-2           0.108-2
ii  libgdk-pixbuf2.0-0         2.36.4-1
ii  libglib2.0-0               2.50.2-2
ii  libgtk-3-0                 3.22.7-1
ii  libgtksourceview-3.0-1     3.22.2-1
ii  libgtop-2.0-10             2.34.2-1
ii  libice6                    2:1.0.9-1+b1
ii  libiw30                    30~pre9-12
ii  libmate-panel-applet-4-1   1.16.0-1
ii  libmateweather1            1.16.1-2
ii  libnotify4                 0.7.7-1
ii  libpango-1.0-0             1.40.3-3
ii  libpangocairo-1.0-0        1.40.3-3
ii  libpolkit-gobject-1-0      0.105-17
ii  libsm6                     2:1.2.2-1+b1
ii  libupower-glib3            0.99.4-4
ii  libwnck-3-0                3.20.1-2
ii  libx11-6                   2:1.6.4-2
ii  libxml2                    2.9.4+dfsg1-2.1
ii  mate-applets-common        1.16.0-1
ii  mate-panel                 1.16.0-1
ii  python                     2.7.13-1
ii  python-gi                  3.22.0-2

Versions of packages mate-applets recommends:
ii  cpufrequtils         008-1
ii  mate-media           1.16.0-1
ii  mate-polkit          1.16.0-2
ii  mate-system-monitor  1.16.0-1

mate-applets suggests no packages.

Versions of packages python2.7 depends on:
ii  libpython2.7-stdlib  2.7.13-2
ii  mime-support         3.60
ii  python2.7-minimal    2.7.13-2

python2.7 recommends no packages.

Versions of packages python2.7 suggests:
ii  binutils       2.27.90.20170118-1
pn  python2.7-doc  <none>

-- no debconf information

--- End Message ---
--- Begin Message ---
Package: mate-applets
Version: 1.19.4-0ubuntu1
done

On Fri, Jan 20, 2017 at 08:56:50PM +0100, Steve Cotton wrote:
> Doing a keyword search with pydoc results in an error message from the 
> mate-invest applet's
> /usr/lib/python2.7/dist-packages/mate_invest/__init__.py

Quoting the upstream changelog for 1.19.4:
  * drop broken invest-applet and all Python dependencies

At the time of writing, "pydoc2.7 -k datetime" segfaults, however that seems to
be an unrelated bug involving the docs for Boost.

Steve

--- End Message ---

Reply via email to